classification
Title: PyUnicode_DecodeUTF8 is not checked for NULL return value
Type: resource usage Stage:
Components: None Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 01:23 by CWRU_Researcher1, last changed 2008-11-25 02:48 by benjamin.peterson. This issue is now closed.

Messages (2)
msg76382 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 01:23
Python-2.5.2/Objects/unicodeobject.c
Line 587

PyUnicode_DecodeUTF8 is not checked for NULL return value
msg76392 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:48
This doesn't need a NULL check. The exception is propagated to the caller.
History
Date User Action Args
2008-11-25 02:48:21benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76392
nosy: + benjamin.peterson
2008-11-25 01:23:45CWRU_Researcher1create