classification
Title: PyObject_CallObject is not checked for NULL return value
Type: resource usage Stage:
Components: Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 01:17 by CWRU_Researcher1, last changed 2008-11-25 02:46 by benjamin.peterson. This issue is now closed.

Messages (3)
msg76380 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 01:17
Python-2.5.2/Modules/_sre.c(PySequence_Fast)
Line 1963

PyObject_CallObject is not checked for NULL return value
msg76381 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 01:20
Python-2.5.2/Modules/_sre.c(join_list)
Line 2023

PyObject_CallObject is not checked for NULL return value
msg76391 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:46
This doesn't need a NULL check. The exception is propagated to the caller.
History
Date User Action Args
2008-11-25 02:46:39benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76391
nosy: + benjamin.peterson
2008-11-25 01:20:23CWRU_Researcher1setmessages: + msg76381
2008-11-25 01:17:26CWRU_Researcher1create