classification
Title: PySequence_List is not checked for NULL return value
Type: resource usage Stage:
Components: Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 01:15 by CWRU_Researcher1, last changed 2008-11-25 02:31 by benjamin.peterson. This issue is now closed.

Messages (2)
msg76379 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 01:15
Python-2.5.2/Objects/abstract.c(PySequence_Fast)
Line 1611

PySequence_List is not checked for NULL return value
msg76386 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:31
There doesn't need to be a NULL check here. The exception is merely
propagated to the caller.
History
Date User Action Args
2008-11-25 02:31:06benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76386
nosy: + benjamin.peterson
2008-11-25 01:15:05CWRU_Researcher1create