classification
Title: hmac.update is not releasing the GIL when openssl's hmac is used
Type: performance Stage: commit review
Components: Extension Modules Versions: Python 3.11, Python 3.10, Python 3.9
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: gregory.p.smith Nosy List: christian.heimes, gregory.p.smith, miss-islington
Priority: normal Keywords: 3.9regression, patch

Created on 2021-05-16 06:54 by gregory.p.smith, last changed 2021-07-07 15:47 by gregory.p.smith. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 26157 merged gregory.p.smith, 2021-05-16 07:03
PR 26187 merged miss-islington, 2021-05-17 07:35
PR 26188 merged miss-islington, 2021-05-17 07:35
Messages (3)
msg393733 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2021-05-16 06:54
This prevents parallel hmac computations.

see michaelforney's comment left on https://github.com/python/cpython/pull/20129
where the problem was introduced when adding support for using OpenSSL's HMAC implementations.

easy fix.  PR coming.

We don't really have a way to unittest for regressions on things like this.
msg393791 - (view) Author: miss-islington (miss-islington) Date: 2021-05-17 08:04
New changeset 60fa8b32dbfe452b81c44d2b8a96325fb19a206d by Miss Islington (bot) in branch '3.10':
bpo-44145: Release the GIL around HMAC_Update. (GH-26157)
https://github.com/python/cpython/commit/60fa8b32dbfe452b81c44d2b8a96325fb19a206d
msg393792 - (view) Author: miss-islington (miss-islington) Date: 2021-05-17 08:07
New changeset 2057ce87498fc30bcd358286175fe5ea34eac9da by Miss Islington (bot) in branch '3.9':
[3.9] bpo-44145: Release the GIL around HMAC_Update. (GH-26157) (GH-26188)
https://github.com/python/cpython/commit/2057ce87498fc30bcd358286175fe5ea34eac9da
History
Date User Action Args
2021-07-07 15:47:58gregory.p.smithsetstatus: open -> closed
resolution: fixed
stage: patch review -> commit review
2021-05-17 08:07:56miss-islingtonsetmessages: + msg393792
2021-05-17 08:04:04miss-islingtonsetmessages: + msg393791
2021-05-17 07:35:30miss-islingtonsetpull_requests: + pull_request24805
2021-05-17 07:35:25miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request24804
2021-05-16 07:03:46gregory.p.smithsetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request24791
2021-05-16 06:54:04gregory.p.smithcreate