classification
Title: Failure to check return value of PyBool_FromLong for NULL
Type: resource usage Stage:
Components: None Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 00:50 by CWRU_Researcher1, last changed 2008-11-25 02:43 by benjamin.peterson. This issue is now closed.

Messages (2)
msg76375 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 00:50
/home/rxc92/project/Python-2.5.2/Objects/unicodeobject.c(unicode_istitle)
Line 5953

Failed to check that the return value of PyBool_FromLong is not NULL

Referenced:
http://www.python.org/doc/2.5.2/api/boolObjects.html#l2h-400
msg76389 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:43
None of these cases need checks. The exception is propagated to the caller.
History
Date User Action Args
2008-11-25 02:43:16benjamin.petersonsetstatus: open -> closed
resolution: not a bug
2008-11-25 02:43:04benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg76389
2008-11-25 00:50:29CWRU_Researcher1create