classification
Title: Python 3.9 UWP does not create key in PythonCore
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: BinToss, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2021-05-04 04:30 by BinToss, last changed 2021-05-04 19:55 by steve.dower. This issue is now closed.

Messages (2)
msg392851 - (view) Author: BinToss (BinToss) Date: 2021-05-04 04:30
On Windows, dependent applications such as VapourSynth look for Python's path via the entries in HKLM\\SOFTWARE\\Python\\PythonCore\\.
However, the Python 3.8 and 3.9 UWP releases don't create and write to their respective subkeys. Only the Win32 releases write to their subkeys.

See https://github.com/vapoursynth/vapoursynth/issues/684
msg392940 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-05-04 19:55
Correct. It does, however, write to the lookaside space, which Windows will map back if you access it.

So reading HKLM\Software\Python\PythonCore\3.9 will return all the values that would be there. It's only enumeration that doesn't work. I've reported that to the team responsible, and they think it's not necessary, so I have no qualms about saying that you should *also* look in "SOFTWARE\\Microsoft\\AppModel\\Lookaside\\user\\Software\\Python\\PythonCore". (And if another redistributor also does a UWP package of Python, they'll have their own registry section for it to go into.)

Not writing into shared registry locations is one of the *best* features of this form of packaging, so I'm not inclined to try too hard to break it. Overall the robustness and stability is worthwhile, so it'll just fall to tool developers to catch up a bit, or alternatively win over the team that could just fix it properly.
History
Date User Action Args
2021-05-04 19:55:55steve.dowersetstatus: open -> closed
resolution: not a bug
messages: + msg392940

stage: resolved
2021-05-04 04:54:20ned.deilysetnosy: + tim.golden, steve.dower, zach.ware, paul.moore
components: + Windows, - Installation
2021-05-04 04:30:58BinTosscreate