classification
Title: Docstring for "Lib/string.py" is outdated
Type: Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: georg.brandl, terry.reedy, thp
Priority: normal Keywords: patch

Created on 2008-11-20 12:42 by thp, last changed 2008-11-22 08:31 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
Lib_string_py-docstring.patch thp, 2008-11-20 12:42 trivial patch to fix docstring
Messages (3)
msg76097 - (view) Author: Thomas Perl (thp) Date: 2008-11-20 12:42
The docstring in "Lib/string.py" in the source of "Python 3.0rc2" is
wrong. It currently says "lowercase", "uppercase" and "letters" where it
should say "ascii_lowercase", "ascii_uppercase" and "ascii_letters".
msg76231 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-11-22 02:37
In rc3 also: The problem is partial update:

DESCRIPTION
    Public module variables:
    
    whitespace -- a string containing all characters considered whitespace
    lowercase -- a string containing all characters considered lowercase
letters
    uppercase -- a string containing all characters considered uppercase
letters
    letters -- a string containing all characters considered letters
...
DATA
    ascii_letters = 'abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ'
    ascii_lowercase = 'abcdefghijklmnopqrstuvwxyz'
    ascii_uppercase = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ'

The latter is indeed correct:
>>> dir(string)
[..., 'ascii_letters', 'ascii_lowercase', 'ascii_uppercase', ...]
msg76235 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-11-22 08:31
Fixed in r67329.
History
Date User Action Args
2008-11-22 08:31:19georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg76235
2008-11-22 02:37:12terry.reedysetnosy: + terry.reedy
messages: + msg76231
2008-11-20 12:42:47thpcreate