classification
Title: about the method: title()
Type: behavior Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: chinkikoo227, christian.heimes
Priority: normal Keywords:

Created on 2021-03-05 14:09 by chinkikoo227, last changed 2021-03-05 14:47 by christian.heimes. This issue is now closed.

Files
File name Uploaded Description Edit
title().png chinkikoo227, 2021-03-05 14:09
Messages (2)
msg388153 - (view) Author: Qihao Chen (chinkikoo227) Date: 2021-03-05 14:09
Hello, I'm a student from China, and I think there is a bug in Python3.7.

When I use the method "title()", I think the method should not make "'s" upper.

I would appreciate it if you could consider my advice.
msg388154 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2021-03-05 14:47
This behavior is documented, https://docs.python.org/3/library/stdtypes.html#str.title

> The algorithm uses a simple language-independent definition of a word as groups of consecutive letters. The definition works in many contexts but it means that apostrophes in contractions and possessives form word boundaries, which may not be the desired result

The documentation also mentions a workaround.
History
Date User Action Args
2021-03-05 14:47:44christian.heimessetstatus: open -> closed

nosy: + christian.heimes
messages: + msg388154

resolution: not a bug
stage: resolved
2021-03-05 14:09:39chinkikoo227create