classification
Title: xmlrpc.client - default 'SlowParser' not defined
Type: Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mwatkins, vstinner
Priority: normal Keywords:

Created on 2008-11-17 20:55 by mwatkins, last changed 2010-01-31 01:45 by vstinner. This issue is now closed.

Messages (3)
msg75980 - (view) Author: Mike Watkins (mwatkins) Date: 2008-11-17 20:55
Running example code from docs:

http://docs.python.org/dev/3.0/library/xmlrpc.client.html#example-of-
client-usage

z% python
Python 3.0rc2+ (py3k:67152, Nov  7 2008, 16:48:55) 
[GCC 4.2.1 20070719  [FreeBSD]] on freebsd7
Type "help", "copyright", "credits" or "license" for more information.
>>> str(None)
'None'
>>> from xmlrpc.client import ServerProxy, Error
>>> server = ServerProxy("http://betty.userland.com")
>>> print(server)
<ServerProxy for betty.userland.com/RPC2>
>>> print(server)
<ServerProxy for betty.userland.com/RPC2>
>>> print(server.examples.getStateName(41))
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.0/xmlrpc/client.py", line 1095, in 
__call__
    return self.__send(self.__name, args)
  File "/usr/local/lib/python3.0/xmlrpc/client.py", line 1353, in 
__request
    verbose=self.__verbose
  File "/usr/local/lib/python3.0/xmlrpc/client.py", line 1136, in 
request
    return self._parse_response(resp, None)
  File "/usr/local/lib/python3.0/xmlrpc/client.py", line 1235, in 
_parse_response
    p, u = self.getparser()
  File "/usr/local/lib/python3.0/xmlrpc/client.py", line 1145, in 
getparser
    return getparser(use_datetime=self._use_datetime)
  File "/usr/local/lib/python3.0/xmlrpc/client.py", line 975, in 
getparser
    parser = SlowParser(target)
NameError: global name 'SlowParser' is not defined


No definition of SlowParser in client.py:

/src/py3k/Lib/xmlrpc% grep -n SlowParser client.py
116:  SlowParser     Slow but safe standard parser (based on xmllib)
975:            parser = SlowParser(target)
msg76059 - (view) Author: Mike Watkins (mwatkins) Date: 2008-11-19 17:13
Running the same code today passes, despite the fact I'm still running 
the same svn version. Bizarre. 

However the core reported issue - SlowParser being undefined in the 
module, remains.
msg98588 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2010-01-31 01:45
I'm unable to reproduce the bug on py3k nor python3.1. Reopen the issue if the bug reappears.
History
Date User Action Args
2010-01-31 01:45:54vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg98588

resolution: not a bug
2008-11-19 17:13:50mwatkinssetmessages: + msg76059
2008-11-17 20:55:58mwatkinscreate