classification
Title: RotatingFileHandler breaks file type associations
Type: behavior Stage: resolved
Components: Extension Modules Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: kh14821, rhettinger, vinay.sajip
Priority: normal Keywords:

Created on 2021-02-27 22:44 by kh14821, last changed 2021-03-04 05:39 by vinay.sajip. This issue is now closed.

Files
File name Uploaded Description Edit
logger_bug.py kh14821, 2021-02-27 22:44 Python script
Messages (7)
msg387793 - (view) Author: Kevin Hollingshead (kh14821) Date: 2021-02-27 22:44
The filenames generated by logging.RotatingFileHandler breaks the ability to associate a program (e.g. notepad++, sublime text, etc.) with the log files using Windows or OSX file associations because the extension is overridden by the added suffix. For example, if I specify the filename as "test.log" for a TimeBasedRotatingFileHandler with a suffix of "%Y%m%d", rolled over files are named test.log.YYYYMMDD. There is no way to associate a program with this type of file extension. A good non-breaking fix would be to add a parameter "extension" to RotatingFileHandler, and if specified would be applied to all filenames. Thus if I specify filename="test" and "extension="log" for my handler it would give "test.log" for the initial file and "test.YYYYMMDD.log" for rollover files.
msg387814 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2021-02-28 18:26
+1 The ability to customize the filenames seems like a reasonable feature request.  Perhaps an optional *format* option could introduced.
msg387870 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2021-03-01 15:13
As per the documentation at

https://docs.python.org/3/library/logging.handlers.html#logging.handlers.BaseRotatingHandler.namer

You can set the handler's "namer" attribute to a callable that returns a computed name for the rotated file - this can be computed as per your requirements. The cookbook also has an entry about this:

https://docs.python.org/3/howto/logging-cookbook.html#using-a-rotator-and-namer-to-customize-log-rotation-processing
msg387949 - (view) Author: Kevin Hollingshead (kh14821) Date: 2021-03-02 18:14
Thanks Vinay, I was able to do this with:

def namer(name):
    return name.replace(".log", "") + ".log"

Then when initializing the logger:

handler.namer = namer

My full initializer script:

import os
import logging
from logging.handlers import TimedRotatingFileHandler
from config import constants

def namer(name):
    return name.replace(".log", "") + ".log"

def init(baseFilename):
    logPath = constants.LOGGING_DIR
    envSuffix = '-prod' if constants.ENV == 'prod' else '-dev'
    logFilename = os.path.join(logPath, baseFilename + envSuffix + '.log')
    print(f"Logging to {logFilename}")

    handler = TimedRotatingFileHandler(logFilename,
        when = "midnight",
        backupCount = 30,
        encoding = 'utf8')
    handler.setLevel(logging.DEBUG)
    handler.suffix = "%Y%m%d"
    handler.namer = namer

    formatter = logging.Formatter('%(asctime)s %(levelname)s %(message)s
[%(module)s:%(lineno)d]')
    handler.setFormatter(formatter)

    logging.basicConfig(
        handlers = [handler],
        format = '%(asctime)s %(levelname)s %(message)s
[%(module)s:%(lineno)d]',
        level = logging.DEBUG,
        datefmt = '%Y-%m-%d %H:%M:%S')

if __name__ == '__main__':
    init('testing')
    logging.error("ohai")
    logging.debug("ohai debug")
    logging.getLogger().handlers[0].doRollover()
    logging.error("ohai next day")
    logging.debug("ohai debug next day")

On Mon, Mar 1, 2021 at 8:13 AM Vinay Sajip <report@bugs.python.org> wrote:

>
> Vinay Sajip <vinay_sajip@yahoo.co.uk> added the comment:
>
> As per the documentation at
>
>
> https://docs.python.org/3/library/logging.handlers.html#logging.handlers.BaseRotatingHandler.namer
>
> You can set the handler's "namer" attribute to a callable that returns a
> computed name for the rotated file - this can be computed as per your
> requirements. The cookbook also has an entry about this:
>
>
> https://docs.python.org/3/howto/logging-cookbook.html#using-a-rotator-and-namer-to-customize-log-rotation-processing
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue43344>
> _______________________________________
>
msg387962 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2021-03-02 20:07
> Thanks Vinay, I was able to do this

Glad to hear it, Kevin. That namer is exactly what I had in my mind's eye ;-)

So shall I close the issue?
msg387963 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2021-03-02 20:08
I'll add to the cookbook recipe with this real-world example, when I get a chance.
msg387964 - (view) Author: Kevin Hollingshead (kh14821) Date: 2021-03-02 20:18
Sure. Thanks for your help.

On Tue, Mar 2, 2021, 1:08 PM Vinay Sajip <report@bugs.python.org> wrote:

>
> Vinay Sajip <vinay_sajip@yahoo.co.uk> added the comment:
>
> I'll add to the cookbook recipe with this real-world example, when I get a
> chance.
>
> ----------
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue43344>
> _______________________________________
>
History
Date User Action Args
2021-03-04 05:39:50vinay.sajipsetstatus: open -> closed
resolution: not a bug
stage: resolved
2021-03-02 20:18:17kh14821setmessages: + msg387964
2021-03-02 20:08:35vinay.sajipsetmessages: + msg387963
2021-03-02 20:07:33vinay.sajipsetmessages: + msg387962
2021-03-02 18:14:11kh14821setmessages: + msg387949
2021-03-01 15:13:27vinay.sajipsetmessages: + msg387870
2021-02-28 18:26:16rhettingersetnosy: + rhettinger, vinay.sajip

messages: + msg387814
versions: + Python 3.10
2021-02-27 22:44:17kh14821create