classification
Title: Python is not responding after running program
Type: behavior Stage: resolved
Components: macOS Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: diasybarrett, ned.deily, ronaldoussoren, steven.daprano
Priority: normal Keywords:

Created on 2021-02-12 21:55 by diasybarrett, last changed 2021-03-02 16:53 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
Screen Shot 2021-02-12 at 23.55.56.png diasybarrett, 2021-02-12 21:55
Screen Shot 2021-02-12 at 23.56.46.png diasybarrett, 2021-02-12 21:55
Messages (2)
msg386882 - (view) Author: Diasy Barrett (diasybarrett) Date: 2021-02-12 21:55
Good day all
I am very new to Python programming so forgive me.

The Python application is not responding after I run my program.
msg386915 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2021-02-13 07:50
Hi Diasy, welcome!

Please don't post screen shots of code. That makes it difficult or impossible for the blind and visually impaired to contribute, and it means that we have to retype your code from scratch to run it, which may introduce new errors. Instead, please copy and paste the code as text into your bug report, or attach it as a .py file.

I'm not entirely sure what your bug report is here. Your program is stuck in a loop:

    while True:
        wn.update

which does nothing and goes nowhere. (By the way, I think you forgot to call the update method: it should be `wn.update()` with round brackets.)

Does the program respond to you typing Ctrl-C? You might need to do that from your command line or IDE, the "Pong" window itself probably won't respond to it.

So I'm not sure what bug you think you have found. It looks like it is probably running normally to me.

(Disclaimer: I am not using Mac OS, so perhaps the behaviour is different on my machine than on yours.)
History
Date User Action Args
2021-03-02 16:53:59zach.waresetstatus: open -> closed
resolution: not a bug
stage: resolved
2021-02-13 07:50:27steven.dapranosetnosy: + steven.daprano
messages: + msg386915
2021-02-12 21:55:37diasybarrettsetfiles: + Screen Shot 2021-02-12 at 23.56.46.png
2021-02-12 21:55:12diasybarrettcreate