classification
Title: import aiohttp crash closes Python from Windows Installer
Type: Stage: resolved
Components: Windows Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: giovanniwijaya, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2021-02-03 08:31 by giovanniwijaya, last changed 2021-02-04 00:31 by giovanniwijaya. This issue is now closed.

Messages (5)
msg386180 - (view) Author: Giovanni Wijaya (giovanniwijaya) * Date: 2021-02-03 08:31
Since Python 3.10.0a4, importing aiohttp crash closes Python, only on Python installed from Windows Installer x64. Python installed in Debian (both from source and otherwise) does not produce this issue.
msg386195 - (view) Author: Giovanni Wijaya (giovanniwijaya) * Date: 2021-02-03 11:07
Update: I tried installing Python from source in x64, and same issue persists.
msg386220 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-02-03 17:23
Do you know whether aiohttp has released updated packages for the later alphas yet? Or have you rebuilt it from source as well?

Alphas are not backwards compatible with each other, so extension modules need to be rebuilt for each update (and I'm pretty sure aiohttp relies on extension modules).
msg386462 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-02-03 22:37
I just installed aiohttp into 3.10.0a5 without issue, though some packages did have to rebuild. I'm very much leaning towards marking this as external, but interested to hear whether Giovanni has done something different that should have worked.
msg386472 - (view) Author: Giovanni Wijaya (giovanniwijaya) * Date: 2021-02-04 00:31
I'm not sure whether aiohttp has released packages specifically for the alphas, but I tried rebuilding aiohttp and its extension modules and it currently works. Thank you for the solution.
History
Date User Action Args
2021-02-04 00:31:29giovanniwijayasetstatus: open -> closed
resolution: not a bug
messages: + msg386472

stage: resolved
2021-02-03 22:37:32steve.dowersetmessages: + msg386462
2021-02-03 17:23:03steve.dowersetmessages: + msg386220
2021-02-03 11:07:51giovanniwijayasetmessages: + msg386195
2021-02-03 08:31:31giovanniwijayacreate