classification
Title: csv package in class
Type: behavior Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eric.smith, tobias.muellner250502
Priority: normal Keywords:

Created on 2021-02-02 15:51 by tobias.muellner250502, last changed 2021-02-02 21:39 by eric.smith. This issue is now closed.

Messages (2)
msg386151 - (view) Author: Tobias Müllner (tobias.muellner250502) Date: 2021-02-02 15:51
Hello

I want to use the csv package in a class.

If I use the writer instance as local variable in the class it works perfectly but if I use it as class-variable (self.writer) it does not work anymore. 

Does anyone have the same behaviour?

Yours Toby

By the way, sorry for my bad English :(
msg386172 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2021-02-02 21:39
This isn't a forum for helping users with questions about Python, it's for reporting bugs in Python.

I suggest you ask this question on the python-list mailing list: https://mail.python.org/mailman/listinfo/python-list

And when you do ask your question there, you should include the code that shows what you have tried and what error you're getting.

Good luck! And your English is perfectly fine!
History
Date User Action Args
2021-02-02 21:39:14eric.smithsetstatus: open -> closed

nosy: + eric.smith
messages: + msg386172

resolution: not a bug
stage: resolved
2021-02-02 15:51:43tobias.muellner250502create