classification
Title: unwanted label showing up in ttk.LabeledScale
Type: Stage: resolved
Components: Tkinter Versions: Python 3.9
process
Status: closed Resolution: out of date
Dependencies: Superseder: ttk LabeledScale: label covered by hidden element
View: 40219
Assigned To: Nosy List: Akuli, serhiy.storchaka
Priority: normal Keywords:

Created on 2021-01-24 20:20 by Akuli, last changed 2021-01-24 21:09 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
ssss.png Akuli, 2021-01-24 20:20 screenshot
Messages (2)
msg385591 - (view) Author: Akuli (Akuli) Date: 2021-01-24 20:20
import tkinter
from tkinter import ttk
root = tkinter.Tk()
ttk.LabeledScale(root).pack()
root.mainloop()


Run this code and move the slider to center. You see something in front of the number. The problem is this line in ttk.py:

        tmp = Label(self).pack(side=label_side) # place holder

I tried deleting it, but then the label doesn't show up at all, and what remains is just a scale. Packing with a different side works, but that feels like a hack.
msg385592 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2021-01-24 21:09
It has already been fixed in issue40219. Just wait next bugfix release.
History
Date User Action Args
2021-01-24 21:09:36serhiy.storchakasetstatus: open -> closed

superseder: ttk LabeledScale: label covered by hidden element

nosy: + serhiy.storchaka
messages: + msg385592
resolution: out of date
stage: resolved
2021-01-24 20:20:49Akulicreate