classification
Title: Parts of the API will be removed in Python 4.0 ?
Type: behavior Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: MichaelClerx, docs@python, terry.reedy
Priority: normal Keywords:

Created on 2021-01-22 15:01 by MichaelClerx, last changed 2021-01-23 19:34 by terry.reedy. This issue is now closed.

Messages (2)
msg385501 - (view) Author: Michael Clerx (MichaelClerx) Date: 2021-01-22 15:01
The unicode C-API documentation has a deprecation warning on this page:

  https://docs.python.org/3.9/c-api/unicode.html#deprecated-py-unicode-apis

stating some functions are

  Deprecated since version 3.3, will be removed in version 4.0.

But as far as I understand there are no current plans for a 4.0.
Should the text read "removed in version 3.10" ?
msg385562 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2021-01-23 19:34
Questions should be asked on Q&A forums, like python_list.
Check Removed section of What's New in 3.10.
https://docs.python.org/3.10/whatsnew/3.10.html#removed
History
Date User Action Args
2021-01-23 19:34:29terry.reedysetstatus: open -> closed

type: behavior

nosy: + terry.reedy
messages: + msg385562
resolution: not a bug
stage: resolved
2021-01-22 15:01:43MichaelClerxcreate