classification
Title: python3.8.9, python3.9.2 test_embed test_tabnanny failed
Type: compile error Stage: resolved
Components: Tests Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_embed and test_tabnanny fails if the current directory is non-ASCII
View: 44031
Assigned To: Nosy List: asholomitskiy84, terry.reedy, vstinner, wingarmac
Priority: normal Keywords:

Created on 2021-01-22 11:35 by asholomitskiy84, last changed 2021-05-26 21:19 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
lastlog wingarmac, 2021-02-10 03:15 lastlog
make_test_3.8.9.log asholomitskiy84, 2021-05-04 11:10
log_make_test 3.9.2.log asholomitskiy84, 2021-05-04 11:22
Messages (10)
msg385490 - (view) Author: Alexei S (asholomitskiy84) Date: 2021-01-22 11:35
== Tests result: FAILURE then FAILURE ==

396 tests OK.

2 tests failed:
    test_embed test_tabnanny

27 tests skipped:
    test_bz2 test_curses test_dbm_gnu test_dbm_ndbm test_devpoll
    test_gdb test_idle test_ioctl test_kqueue test_lzma test_msilib
    test_ossaudiodev test_readline test_smtpnet test_ssl
    test_startfile test_tcl test_tix test_tk test_ttk_guionly
    test_ttk_textonly test_turtle test_winconsoleio test_winreg
    test_winsound test_zipfile64 test_zoneinfo

2 re-run tests:
    test_embed test_tabnanny

Total duration: 10 min 58 sec
Tests result: FAILURE then FAILURE
make: *** [Makefile:1199: test] Error 2
msg385559 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2021-01-23 18:34
What system, what errors (copy-paste failure blocks)?
msg386755 - (view) Author: Tony Martin Berbel (wingarmac) Date: 2021-02-10 03:06
I had the same error
I ran the make test command with >&log 
But I don't know where to look for the log file
msg386756 - (view) Author: Tony Martin Berbel (wingarmac) Date: 2021-02-10 03:15
I found lastlog and attached it !
msg386759 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2021-02-10 03:59
A 300 KB file of unknown type that has to be downloaded and opened with an unknown program is pretty useless.  Please state system/OS, exact Python release, command run, and copy-paste the errors here on the web page.

I do not see test_embed or test_tabnanny errors on Windows or Mac.  Are you 2 on *nix?

For test_embed, all tests are skipped for me because _testembed.exe does not exist.  I am guessing that this is normal since the first line of the file says 
# Run the tests in Programs/_testembed.c (tests for the CPython embedding APIs)
This suggests that it should never fail when running the test suite normally.  Victor?
msg386820 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-02-11 07:53
Try to run directly the two failing tests in verbose mode, copy/paste the output into a file and attach the file here:

python -m test test_embed test_tabnanny -v
msg386830 - (view) Author: Tony Martin Berbel (wingarmac) Date: 2021-02-11 16:31
My system crashed completely. I reinstalled Ubuntu. Sorry I couldn't help
more ... :(
___________________________________________

MARTIN BERBEL, Tony
GSM: +32 (0) 477 / 33.12.48

------------------------------

Le mer. 10 févr. 2021 à 04:06, Tony Martin Berbel <report@bugs.python.org>
a écrit :

>
> Tony Martin Berbel <wingarmac@gmail.com> added the comment:
>
> I had the same error
> I ran the make test command with >&log
> But I don't know where to look for the log file
>
> ----------
> nosy: +wingarmac
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue43001>
> _______________________________________
>
msg386831 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-02-11 18:24
Ok, I close the issue.
msg392874 - (view) Author: Alexei S (asholomitskiy84) Date: 2021-05-04 11:10
python 3.8.9 also show compile problems
my system: Linux Mint 20.1 Cinnamon (Cinnamon 4.8.6)
kernel 5.8.0-48-generic
$uname -a
Linux home 5.8.0-48-generic #54~20.04.1-Ubuntu SMP Sat Mar 20 13:40:25 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I tried to execute problem code from tabnanny in PyCharm - that's ok
from test.support import (captured_stderr, captured_stdout, script_helper, findfile, unlink)


def validate_cmd(self, *args, stdout="", stderr="", partial=False):
    """Common function to assert the behaviour of command line interface."""
    _, out, err = script_helper.assert_python_ok('-m', 'tabnanny', *args)
    # Note: The `splitlines()` will solve the problem of CRLF(\r) added
    # by OS Windows.
    out = out.decode('ascii')
    err = err.decode('ascii')
    if partial:
        for std, output in ((stdout, out), (stderr, err)):
            _output = output.splitlines()
            for _std in std.splitlines():
                with self.subTest(std=_std, output=_output):
                    self.assertIn(_std, _output)
    else:
        self.assertListEqual(out.splitlines(), stdout.splitlines())
        self.assertListEqual(err.splitlines(), stderr.splitlines())

    def test_command_usage(self):
        path = findfile('~/Загрузки/Python-3.8.9/Lib/test/tabnanny.py')
        stderr = f"Usage: {path} [-v] file_or_directory ..."

        self.validate_cmd(stderr=stderr)
msg394465 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-05-26 21:19
Duplicate of bpo-44031.
History
Date User Action Args
2021-05-26 21:19:33vstinnersetsuperseder: test_embed and test_tabnanny fails if the current directory is non-ASCII
resolution: out of date -> duplicate
messages: + msg394465
2021-05-04 11:54:47asholomitskiy84setstatus: open -> closed
resolution: out of date
2021-05-04 11:23:19asholomitskiy84settitle: python3.8.9, python3.9.1 test_embed test_tabnanny failed -> python3.8.9, python3.9.2 test_embed test_tabnanny failed
2021-05-04 11:22:17asholomitskiy84setfiles: + log_make_test 3.9.2.log
2021-05-04 11:10:45asholomitskiy84setversions: + Python 3.8
2021-05-04 11:10:13asholomitskiy84setfiles: + make_test_3.8.9.log

messages: + msg392874
title: python3.9.1python3.9.1 test_embed test_tabnanny failed -> python3.8.9, python3.9.1 test_embed test_tabnanny failed
2021-05-04 11:01:54asholomitskiy84settitle: python3.9.1 test_embed test_tabnanny failed -> python3.9.1python3.9.1 test_embed test_tabnanny failed
2021-05-04 11:01:25asholomitskiy84setstatus: closed -> open
resolution: out of date -> (no value)
2021-02-11 18:24:57vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg386831

stage: resolved
2021-02-11 16:31:42wingarmacsetmessages: + msg386830
2021-02-11 07:53:47vstinnersetmessages: + msg386820
2021-02-10 03:59:54terry.reedysetnosy: + vstinner
messages: + msg386759
2021-02-10 03:15:27wingarmacsetfiles: + lastlog

messages: + msg386756
2021-02-10 03:06:22wingarmacsetnosy: + wingarmac
messages: + msg386755
2021-01-23 18:34:16terry.reedysetnosy: + terry.reedy
messages: + msg385559
2021-01-22 11:35:38asholomitskiy84create