classification
Title: Inconsistent state after autoreconf
Type: behavior Stage: resolved
Components: Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: agbaroni
Priority: normal Keywords:

Created on 2020-12-21 13:14 by agbaroni, last changed 2020-12-21 20:28 by agbaroni. This issue is now closed.

Messages (2)
msg383517 - (view) Author: (agbaroni) Date: 2020-12-21 13:14
git clone https://github.com/python/cpython && cd cpython && autoreconf && ./configure --with-pydebug gives the following error:

checking for --enable-optimizations... no
./configure: line 6443: syntax error near unexpected token `-fno-semantic-interposition,'
./configure: line 6443: `      AX_CHECK_COMPILE_FLAG(-fno-semantic-interposition,'

Here (section 1.5): https://cpython-devguide.readthedocs.io/setup/ speaks about only autoreconf.
msg383551 - (view) Author: (agbaroni) Date: 2020-12-21 20:28
I'm closing the issue: I hadn't the autoconf-archive package on Fedora 33.
History
Date User Action Args
2020-12-21 20:28:21agbaronisetstatus: open -> closed
resolution: not a bug
messages: + msg383551

stage: resolved
2020-12-21 13:14:59agbaronicreate