classification
Title: __init_subclass__ only called for first subclass when class has multiple inheritance
Type: behavior Stage: resolved
Components: Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ccgahagan, ethan.furman
Priority: normal Keywords:

Created on 2020-12-18 11:17 by ccgahagan, last changed 2020-12-24 22:19 by ethan.furman. This issue is now closed.

Files
File name Uploaded Description Edit
SubClass.py ccgahagan, 2020-12-18 11:17 shows issue with multiple inheritance and __init_subclass__
Messages (1)
msg383707 - (view) Author: Ethan Furman (ethan.furman) * (Python committer) Date: 2020-12-24 22:19
The two subclasses in the test script are not calling super().  When they do, both __init_subclasses__ are called.
History
Date User Action Args
2020-12-24 22:19:56ethan.furmansetstatus: open -> closed

nosy: + ethan.furman
messages: + msg383707

resolution: not a bug
stage: resolved
2020-12-18 11:17:49ccgahagancreate