classification
Title: Propose: Data model explict about __annotations__ key ordering.
Type: Stage: resolved
Components: Documentation Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, pbryan
Priority: normal Keywords: patch

Created on 2020-12-16 20:51 by pbryan, last changed 2020-12-16 21:19 by pbryan. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 23808 closed pbryan, 2020-12-16 20:53
Messages (2)
msg383204 - (view) Author: Paul Bryan (pbryan) * Date: 2020-12-16 20:51
Currently the data model documentation does not specify the order of keys in __annotations__ dictionary. It is currently in the order that arguments or attributes are declared. I propose to make this explicit.

Rationale: Having order explicitly specified in the documentation makes it a documented feature that code can depend on. Current code cannot safely rely on this behavior.
msg383205 - (view) Author: Paul Bryan (pbryan) * Date: 2020-12-16 21:19
Retracting.
History
Date User Action Args
2020-12-16 21:19:17pbryansetstatus: open -> closed
resolution: not a bug
messages: + msg383205

stage: patch review -> resolved
2020-12-16 20:53:45pbryansetkeywords: + patch
stage: patch review
pull_requests: + pull_request22668
2020-12-16 20:51:41pbryancreate