classification
Title: Hashlib Bug
Type: compile error Stage: resolved
Components: Library (Lib) Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: samit.mohnot.018, zach.ware
Priority: normal Keywords:

Created on 2020-12-16 18:11 by samit.mohnot.018, last changed 2020-12-16 18:53 by zach.ware. This issue is now closed.

Messages (2)
msg383198 - (view) Author: Samit Mohnot (samit.mohnot.018) Date: 2020-12-16 18:11
Complete output (6 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\Username\AppData\Local\Temp\pip-install-uyjqlzx9\hashlib_973e0ee3f102447498d1d4dca94b7942\setup.py", line 68
        print "unknown OS, please update setup.py"
              ^
    SyntaxError: Missing parentheses in call to 'print'. Did you mean print("unknown OS, please update setup.py")?
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
msg383201 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2020-12-16 18:53
`hashlib` is part of the standard library and thus does not need to be (and should not be :)) installed via pip.
History
Date User Action Args
2020-12-16 18:53:16zach.waresetstatus: open -> closed

nosy: + zach.ware
messages: + msg383201

resolution: not a bug
stage: resolved
2020-12-16 18:11:52samit.mohnot.018create