classification
Title: IDLE: Context lines not working correctly
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: terry.reedy Nosy List: terry.reedy
Priority: normal Keywords:

Created on 2020-12-14 11:29 by terry.reedy, last changed 2020-12-15 04:15 by terry.reedy. This issue is now closed.

Messages (2)
msg382981 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-12-14 11:29
Test: open editor.py in editor.  Turn on Code context with large max lines.  Scroll down to body of _sphinx_version (after line 37).  Nothing appears.  Scroll down to line 82 in EditorWindow.__init__.  'def _sphinx_version' appears.  Scroll up (again with arrow key) to the 'def _sphinx_version' line and it diappears from the context.  Usually repeats.

Is it coincidence that 82 - 37 = 45, the lines in the window?  No.  Shrink window to 26 lines and context line appears when at line 37 + 26 = 63.
msg383032 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-12-15 04:15
This is a false report due to a brain glitch.
History
Date User Action Args
2020-12-15 04:17:35terry.reedyunlinkissue33610 dependencies
2020-12-15 04:15:45terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg383032

stage: test needed -> resolved
2020-12-15 04:03:27terry.reedylinkissue33610 dependencies
2020-12-14 11:29:54terry.reedycreate