classification
Title: Traceback (most recent call last): File "", line 1, in NameError: name 'python' is not defined
Type: behavior Stage: resolved
Components: Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: josh.r, sivakrishnaavvaru, xtreak
Priority: normal Keywords:

Created on 2020-12-04 02:51 by sivakrishnaavvaru, last changed 2021-01-24 12:50 by iritkatriel. This issue is now closed.

Messages (2)
msg382465 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-12-04 05:09
Please attach the program to reproduce the issue along with the full traceback in the issue body. It looks like you are trying to use a variable named 'python' which is not present at the given scope during execution.
msg382467 - (view) Author: Josh Rosenberg (josh.r) * (Python triager) Date: 2020-12-04 07:32
Looks like someone tried to run python inside an interactive Python shell, rather than the command line. I'm moving to pending and will eventually close unless they add a repro for some actual bug.
History
Date User Action Args
2021-01-24 12:50:42iritkatrielsetstatus: pending -> closed
resolution: not a bug
stage: resolved
2020-12-04 07:32:10josh.rsetstatus: open -> pending
nosy: + josh.r
messages: + msg382467

2020-12-04 05:09:28xtreaksettype: compile error -> behavior

messages: + msg382465
nosy: + xtreak
2020-12-04 02:51:26sivakrishnaavvarucreate