classification
Title: better error reporting in ast
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.10
process
Status: closed Resolution: duplicate
Dependencies: Superseder: AST literal_eval exceptions provide no information about line number
View: 28964
Assigned To: Nosy List: BTaskaya, sam-s
Priority: normal Keywords: patch

Created on 2020-12-03 20:24 by sam-s, last changed 2020-12-08 08:09 by BTaskaya. This issue is now closed.

Files
File name Uploaded Description Edit
ast.diff sam-s, 2020-12-03 20:24 proposed patch
Messages (2)
msg382449 - (view) Author: sds (sam-s) Date: 2020-12-03 20:24
ast parsing error locations are hard to pinpoint.
See https://stackoverflow.com/q/46933995/850781.
msg382717 - (view) Author: Batuhan Taskaya (BTaskaya) * (Python committer) Date: 2020-12-08 08:09
This is a duplicate of issue 28964
History
Date User Action Args
2020-12-08 08:09:22BTaskayasetnosy: + BTaskaya
messages: + msg382717
2020-12-08 08:08:52BTaskayasetstatus: open -> closed
stage: resolved
2020-12-07 00:09:50iritkatrielsetsuperseder: AST literal_eval exceptions provide no information about line number
resolution: duplicate
2020-12-03 20:24:18sam-screate