classification
Title: Python launcher: sort order in "Installed versions" off with 3.10
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.10
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Pixmew, ZackerySpytz, gvanrossum, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2020-11-16 01:02 by gvanrossum, last changed 2020-11-16 04:08 by gvanrossum. This issue is now closed.

Messages (4)
msg381049 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2020-11-16 01:02
I installed Python 3.10 on Windows and now the sort order of the versions printed by `py -0` is kind of weird:
```
Installed Pythons found by C:\WINDOWS\py.exe Launcher for Windows
 -3.9-64 *
 -3.8-64
 -3.7-64
 -3.6-64
 -3.5-64
 -3.10-64
```
I'm guessing we're going to have to parse the versions...

(I accidentally first reported this in https://github.com/brettcannon/python-launcher/issues/42.)
msg381057 - (view) Author: Yash Shete (Pixmew) * Date: 2020-11-16 03:11
I would like to try look into this problem. can you please point me into right direction, like: where and what to edit. I am not much experienced but i would like to try.
thankyou
msg381058 - (view) Author: Zackery Spytz (ZackerySpytz) * (Python triager) Date: 2020-11-16 03:14
This seems like a duplicate of bpo-38506 (which already has a PR).
msg381062 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2020-11-16 04:08
Oops. :-)
History
Date User Action Args
2020-11-16 04:08:16gvanrossumsetstatus: open -> closed
resolution: duplicate
messages: + msg381062

stage: needs patch -> resolved
2020-11-16 03:14:48ZackerySpytzsetnosy: + ZackerySpytz
messages: + msg381058
2020-11-16 03:11:13Pixmewsetnosy: + Pixmew
messages: + msg381057
2020-11-16 01:02:01gvanrossumcreate