classification
Title: Python Windows Installation Error 0x800705aa
Type: Stage: resolved
Components: Installation, Windows Versions: Python 3.9
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: eryksun, paul.moore, shakir_juolay, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2020-10-29 13:39 by shakir_juolay, last changed 2020-11-03 06:36 by shakir_juolay. This issue is now closed.

Files
File name Uploaded Description Edit
Pyhon39InstallLog.txt shakir_juolay, 2020-10-29 13:38 Installation log
Capture.JPG shakir_juolay, 2020-10-30 10:43 App execution aliases
Installation Screen Shots - 2.log shakir_juolay, 2020-11-03 06:34
Installation Screen Shots.docx shakir_juolay, 2020-11-03 06:36
Messages (5)
msg379873 - (view) Author: (shakir_juolay) Date: 2020-10-29 13:38
I have recently changed my laptop and my Admin copied everything from D:\Users\sjuolay folder from the old laptop to new laptop. Both Windows 10. I had Python 3.8 64bit on the old laptop. I am trying to install Python 3.9 64bit on my new laptop. But I failed with error 0x800705aa. Attached is the log file.

Also Windows CMD is behaving strange. It does not throw any error on 'python' command but does nothing. It throws error on 'py' command.

Microsoft Windows [Version 10.0.19041.546]
(c) 2020 Microsoft Corporation. All rights reserved.

D:\Users\sjuolay>python

D:\Users\sjuolay>py
'py' is not recognized as an internal or external command,
operable program or batch file.

D:\Users\sjuolay>
msg379879 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2020-10-29 16:04
0x8007_05AA is ERROR_NO_SYSTEM_RESOURCES (1450, 0x05AA) returned as an HRESULT value. This error is usually due to a system call failing with the status code STATUS_INSUFFICIENT_RESOURCES. From "Pyhon39InstallLog.txt", apparently the installer failed to create an uninstall registry key for the current user. Can you successfully install other programs for just the current user (non-elevated)?

For the issue with `python` not doing anything, check `where.exe python`. The first match is the one that CMD would try to execute.
msg379945 - (view) Author: (shakir_juolay) Date: 2020-10-30 10:41
I have installed Zoom without Admin rights in the default folder D:\Users\sjuolay\AppData\Roaming\Zoom\bin. I am assuming it's only me since the application is not installed in Program Files.

Regarding CMD trying to run Python

D:\Users\sjuolay>where.exe python
D:\Users\sjuolay\AppData\Local\Microsoft\WindowsApps\python.exe

D:\Users\sjuolay>echo %PATH%
C:\Program Files\Teradata\Client\16.20\bin;C:\Program Files (x86)\Teradata\Client\16.20\bin;C:\app\product\11.2.0\client_1\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;D:\Users\sjuolay\AppData\Local\Microsoft\WindowsApps;

Looks like I have it because of https://devblogs.microsoft.com/python/python-in-the-windows-10-may-2019-update/

Hope this is not interfering with what I am trying to do.
msg380009 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-10-30 22:40
That python.exe stub being there may be the reason it doesn't appear to do anything. If you aren't fully up to date on preview builds (which is likely), then running it with any arguments will silently exit.

If you run it just as "python.exe" then it will pop open the Microsoft Store to the Python installation there. However, if you're hitting "insufficient resource" errors already then this may also fail.

First I'd make sure you've installed all updates and rebooted your machine. If there's a problem at that point, it's likely to be the cause of other issues.

If it all seems fine, installing from the Microsoft Store might be an option that works for you. (Installing that will also replace the stubs you found, or you can just disable them through the UI you posted. Rest assured, they aren't impacting the installer downloaded from python.org.)
msg380262 - (view) Author: (shakir_juolay) Date: 2020-11-03 06:33
I updated my Windows using Windows Update. Attempted one more time and failed with different errors(images attached).

Tried with Python3.8.1 and failed with initial error 0x800705aa.

Rebooted my machine and tried again with Python3.9 and it worked.

Thanks all for your help.
History
Date User Action Args
2020-11-03 06:36:12shakir_juolaysetstatus: open -> closed
files: + Installation Screen Shots.docx
stage: resolved
2020-11-03 06:34:23shakir_juolaysetfiles: + Installation Screen Shots - 2.log
2020-11-03 06:33:43shakir_juolaysetmessages: + msg380262
2020-10-30 22:40:20steve.dowersetmessages: + msg380009
2020-10-30 10:43:04shakir_juolaysetfiles: + Capture.JPG
2020-10-30 10:41:56shakir_juolaysetmessages: + msg379945
2020-10-29 16:04:31eryksunsetnosy: + eryksun
messages: + msg379879
2020-10-29 14:01:48xtreaksetnosy: + paul.moore, tim.golden, zach.ware, steve.dower
components: + Windows
2020-10-29 13:39:00shakir_juolaycreate