classification
Title: Configure on Apple ARM: "Unexpected output of 'arch' on OSX"
Type: compile error Stage: resolved
Components: Build Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Build failure on macOS 11 (beta)
View: 41100
Assigned To: Nosy List: mistydemeo, ronaldoussoren
Priority: normal Keywords: patch

Created on 2020-10-16 22:47 by mistydemeo, last changed 2020-10-19 10:09 by ronaldoussoren. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 22732 closed mistydemeo, 2020-10-16 22:49
Messages (3)
msg378776 - (view) Author: Misty De Méo (mistydemeo) * Date: 2020-10-16 22:47
Configure's `arch` check on Macs running with Apple Silicon CPUs will fail because the list of acceptable architectures is hardcoded to Intel and PowerPC: https://github.com/python/cpython/blob/master/configure.ac#L2486-L2496

This needs a clause that adds "arm64" as an acceptable arch.
msg378806 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-10-17 09:40
I have a PR that implements support for Apple Silicon:

https://github.com/python/cpython/pull/21564


Sadly this is not yet complete. I hope to make progress again during the core sprint next week.
msg378936 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-10-19 10:09
I'm closing this issue because it is a duplicate of #41100, the patches needed to build on Apple Silicon are more involved than just a configure check.
History
Date User Action Args
2020-10-19 10:09:29ronaldoussorensetstatus: open -> closed
superseder: Build failure on macOS 11 (beta)
messages: + msg378936

type: compile error
resolution: duplicate
stage: patch review -> resolved
2020-10-17 09:40:42ronaldoussorensetnosy: + ronaldoussoren
messages: + msg378806
2020-10-16 22:49:10mistydemeosetkeywords: + patch
stage: patch review
pull_requests: + pull_request21696
2020-10-16 22:47:17mistydemeocreate