classification
Title: sphinx3 renders diffrently docs.python.org for 3.10
Type: performance Stage: resolved
Components: Documentation Versions: Python 3.10, Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Mariatta, corona10, docs@python, lukasz.langa, mdk, miss-islington, pablogsal, rhettinger
Priority: release blocker Keywords: patch

Created on 2020-10-15 11:57 by corona10, last changed 2020-12-26 13:58 by corona10. This issue is now closed.

Files
File name Uploaded Description Edit
python-391.html reynoldsw347, 2020-12-15 13:05 Update
Pull Requests
URL Status Linked Edit
PR 22739 merged corona10, 2020-10-17 14:38
PR 23263 merged miss-islington, 2020-11-13 15:15
PR 23265 merged corona10, 2020-11-13 15:23
Messages (16)
msg378677 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-15 11:57
For example
https://docs.python.org/3.10/c-api/bool.html?highlight=pydict_new#c.PyDict_New

should display 

`Return value: New reference.`

but not, this looks like a regression bug.

other version display `Return value: New reference.` very well.
msg378815 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-17 14:24
This is the regression bug caused by sphinx==3.2.1
If we roll back the sphinx version(2.4.4), it is okay.
I am investigating what causes this issue.
msg378816 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-17 14:31
sphinx2
(Pdb) par[0].attributes
{'ids': ['c._PyObject_New'], 'classes': [], 'names': ['c._PyObject_New'], 'dupnames': [], 'backrefs': [], 'first': False}

sphinx3
(Pdb) par[0].attributes
{'ids': ['c._PyObject_New'], 'classes': [], 'names': [], 'dupnames': [], 'backrefs': [], 'is_multiline': True}

We are using the names attribute for annotation.
msg378817 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-17 14:41
One more regression is that
code background highlight is not applied after sphinx version3

See
https://docs.python.org/3.10/c-api/dict.html#c.PyDict_Next
https://docs.python.org/3.9/c-api/dict.html#c.PyDict_Next
msg378818 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-17 15:07
Okay this is the theme bug.
https://github.com/python/python-docs-theme/pull/57
msg379967 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-30 14:24
@pablogsal

Since this is the developer guide of 3.10.
I would like to suggest as release bloker, if you don't agree you can change it ;)
msg379973 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2020-10-30 14:54
> I would like to suggest as release bloker, if you don't agree you can change it ;)

This is indeed a release blocker, but likely for the beta/release candidate phases.
msg379976 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-10-30 15:18
> but likely for the beta/release candidate phases.

I think so too
msg380896 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-11-13 15:15
New changeset 09490a109faaee9cc393b52742a8575c116c56ba by Dong-hee Na in branch 'master':
bpo-42042: Use ids attribute instead of names attribute (GH-22739)
https://github.com/python/cpython/commit/09490a109faaee9cc393b52742a8575c116c56ba
msg380898 - (view) Author: miss-islington (miss-islington) Date: 2020-11-13 15:30
New changeset 5ad468d4a8cfeb8a320659016964c23735c12a07 by Miss Islington (bot) in branch '3.8':
bpo-42042: Use ids attribute instead of names attribute (GH-22739)
https://github.com/python/cpython/commit/5ad468d4a8cfeb8a320659016964c23735c12a07
msg380903 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-11-13 15:45
New changeset 0f4dd87a31130b245ec4c6ded9fd6f247e700c0d by Dong-hee Na in branch '3.9':
[3.9] bpo-42042: Use ids attribute instead of names attribute (GH-22739) (GH-23265)
https://github.com/python/cpython/commit/0f4dd87a31130b245ec4c6ded9fd6f247e700c0d
msg383318 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2020-12-18 18:59
Is it fixed?
msg383346 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-12-19 01:05
@mdk

No https://github.com/python/python-docs-theme/pull/57 must be fixed ;)
msg383349 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2020-12-19 01:14
The code background highlights really do need to be restored.  Readability has been significantly impaired in 3.10.
msg383352 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2020-12-19 01:48
https://github.com/python/python-docs-theme/pull/57 is landed. We just need a new release of the package to pypi
msg383806 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2020-12-26 13:58
@pablogsal @rhettinger @mdk @Mariatta

Cool!! everything looks okay!
Now I close this issue.

Thank you to everyone who works on this issue!!
History
Date User Action Args
2020-12-26 13:58:36corona10setstatus: open -> closed
resolution: fixed
messages: + msg383806

stage: patch review -> resolved
2020-12-19 01:48:58pablogsalsetmessages: + msg383352
2020-12-19 01:14:39rhettingersetnosy: + rhettinger
messages: + msg383349
2020-12-19 01:06:00corona10setmessages: + msg383346
2020-12-18 18:59:02mdksetmessages: + msg383318
2020-12-15 13:05:41reynoldsw347setfiles: + python-391.html
type: performance
2020-11-13 15:45:09corona10setmessages: + msg380903
2020-11-13 15:30:18miss-islingtonsetmessages: + msg380898
2020-11-13 15:24:19corona10setnosy: + lukasz.langa

versions: + Python 3.8, Python 3.9
2020-11-13 15:23:11corona10setpull_requests: + pull_request22162
2020-11-13 15:15:33miss-islingtonsetnosy: + miss-islington

pull_requests: + pull_request22159
stage: patch review
2020-11-13 15:15:20corona10setmessages: + msg380896
2020-10-30 16:46:18vstinnersetnosy: - vstinner
2020-10-30 15:18:10corona10setmessages: + msg379976
2020-10-30 14:54:17pablogsalsetmessages: + msg379973
2020-10-30 14:24:51corona10setnosy: + pablogsal
messages: + msg379967
2020-10-30 14:23:08corona10setpriority: normal -> release blocker
2020-10-17 15:07:40corona10setmessages: + msg378818
2020-10-17 15:07:11xtreaksetnosy: + mdk
2020-10-17 14:43:00corona10settitle: docs.python.org for 3.10 missing the new refererence record. -> sphinx3 renders diffrently docs.python.org for 3.10
2020-10-17 14:42:06corona10setnosy: + Mariatta
2020-10-17 14:41:55corona10setmessages: + msg378817
stage: patch review -> (no value)
2020-10-17 14:38:08corona10setkeywords: + patch
stage: patch review
pull_requests: + pull_request21702
2020-10-17 14:31:35corona10setmessages: + msg378816
2020-10-17 14:24:05corona10setmessages: + msg378815
2020-10-15 11:57:21corona10create