classification
Title: Exception ignored in: .remove at 0x7f6a325f2ea0>
Type: behavior Stage:
Components: Versions: Python 3.5
process
Status: open Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: jayesh007, zach.ware
Priority: normal Keywords:

Created on 2020-10-13 05:15 by jayesh007, last changed 2020-10-14 16:17 by zach.ware.

Files
File name Uploaded Description Edit
pthon-warning-3.5.4.txt jayesh007, 2020-10-13 05:15
Messages (6)
msg378539 - (view) Author: jayesh (jayesh007) Date: 2020-10-13 05:15
Team,

I am getting python warning messages while run ansible.
Previously I was using python 3.5.3, but after read the below article, I upgraded it with python 3.5.4. 

ref: https://github.com/ansible/ansible/issues/21982

Still facing the same issues. Kindly find attached logs for the same and help us to solve this issue.

Thanks
msg378567 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2020-10-13 16:12
Python 3.5 is now at end-of-life as of September 5, 2020 with the release of 3.5.10, and will not be receiving any more changes.  3.5.4 itself has been obsolete since 3.5.5 was released in February 2018.

You'll need to update to at least Python 3.8.6 (which is the earliest version in bugfix support mode) to get anything changed in Python, but looking at the ansible issue you referenced, it seems likely that this has already been fixed.
msg378604 - (view) Author: jayesh (jayesh007) Date: 2020-10-14 04:57
Dear Team,

are you sure if we upgrade to python 3.8.6 then we will not get these warnings?

For 3.5.4, if this bug is fixed then why i am getting these warnign messages?.

Thanks
msg378618 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2020-10-14 14:12
Unfortunately, no guarantees that upgrading will fix things for you.  However, there's nothing we can do here until you can show that the issue still exists in a supported version of Python.
msg378633 - (view) Author: jayesh (jayesh007) Date: 2020-10-14 16:09
Please check my attached log file.
In that, I am printing ansible version which shows python 3.5.4.
Let me know any other info required from my side.
msg378634 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2020-10-14 16:17
As mentioned in my first message, Python 3.5.4 has been out of support for over 2.5 years now, and 3.5 as a whole has been out of support for a month now.  You'll need to show the problem using Python 3.8.6 or 3.9.0 for anything to be done about it here.
History
Date User Action Args
2020-10-14 16:17:05zach.waresetmessages: + msg378634
2020-10-14 16:09:51jayesh007setmessages: + msg378633
2020-10-14 14:12:58zach.waresetmessages: + msg378618
2020-10-14 04:57:02jayesh007setstatus: pending -> open

messages: + msg378604
2020-10-13 16:12:16zach.waresetstatus: open -> pending

nosy: + zach.ware
messages: + msg378567

type: compile error -> behavior
resolution: out of date
2020-10-13 05:15:39jayesh007create