classification
Title: Deprecate `typing.io` Wrapper Namespace
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.10, Python 3.9, Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Jelle Zijlstra, gvanrossum, levkivskyi, rohitkg98, srittau
Priority: normal Keywords:

Created on 2020-10-10 19:02 by rohitkg98, last changed 2021-05-02 20:36 by Jelle Zijlstra. This issue is now closed.

Messages (3)
msg378412 - (view) Author: Kaushal Rohit (rohitkg98) * Date: 2020-10-10 19:02
The `typing` module has a wrapper namespace in it called `typing.io` which contain I/O stream types.

These types are now a part of the `typing` module itself.

While we are at it, should we also deprecate `typing.re`?
msg378414 - (view) Author: Sebastian Rittau (srittau) * Date: 2020-10-10 20:41
For reference, this came up in https://github.com/python/typeshed/issues/4639#issuecomment-706596656. `typing.io` has never been in typeshed and we decided not to include it. It looks as if it never gained any traction, especially since the types are available from `typing` directly.
msg392729 - (view) Author: Jelle Zijlstra (Jelle Zijlstra) * (Python triager) Date: 2021-05-02 20:36
Closing as a duplicate of https://bugs.python.org/issue38291
History
Date User Action Args
2021-05-02 20:36:57Jelle Zijlstrasetstatus: open -> closed

nosy: + Jelle Zijlstra
messages: + msg392729

resolution: duplicate
stage: resolved
2020-10-11 03:49:17xtreaksetnosy: + gvanrossum, levkivskyi
2020-10-10 20:41:42srittausetnosy: + srittau
messages: + msg378414
2020-10-10 19:02:51rohitkg98create