classification
Title: compilation of sqlite3 fails
Type: compile error Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: brett.cannon, jlp
Priority: normal Keywords:

Created on 2008-10-21 14:36 by jlp, last changed 2009-11-25 20:01 by brett.cannon. This issue is now closed.

Messages (3)
msg75027 - (view) Author: Jacques Lemire (jlp) Date: 2008-10-21 14:36
This is a dump of the error:

Python 3.0rc1 (r30rc1:66499, Oct  6 2008, 12:44:02) 
[GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)] on linux2
Type "help", "copyright", "credits" or "license" for more information. 

>>> import sqlite3
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/devp/altBIN/Python3r/lib/python3.0/sqlite3/__init__.py",
line 24, in <module>
    from sqlite3.dbapi2 import *
  File "/home/devp/altBIN/Python3r/lib/python3.0/sqlite3/dbapi2.py",
line 27, in <module>
    from _sqlite3 import *
ImportError: No module named _sqlite3
msg75034 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2008-10-21 17:18
Looks like sqlite3 was not compiled for you. To verify, run ``make``
again and note what modules it lists at the very end as not built. I bet
it lists sqlite3 there.
msg95723 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2009-11-25 17:20
Please close as invalid.
History
Date User Action Args
2009-11-25 20:01:28brett.cannonsetstatus: open -> closed
resolution: not a bug
2009-11-25 17:21:11floxsetnosy: - flox
2009-11-25 17:20:31floxsetnosy: + flox
messages: + msg95723
2008-10-21 17:18:56brett.cannonsettype: crash -> compile error
messages: + msg75034
nosy: + brett.cannon
title: import of sqlite3 fails -> compilation of sqlite3 fails
2008-10-21 14:36:26jlpcreate