classification
Title: smarter temporary file object
Type: enhancement Stage:
Components: Library (Lib) Versions:
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: Nosy List: collinwinter, djmitche, gvanrossum
Priority: normal Keywords:

Created on 2001-04-12 15:37 by gvanrossum, last changed 2007-03-19 18:53 by collinwinter. This issue is now closed.

Messages (6)
msg53131 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2001-04-12 15:37
Jim Fulton suggested the following:

I wonder if it would be a good idea to have a new kind
of temporary file that stored data in memory unless: 
 
  - The data exceeds some size, or 
 
  - Somebody asks for a fileno. 
 
Then the cgi module (and other apps)  could use this
thing in a uniform way. 
msg53132 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2001-08-09 16:51
Logged In: YES 
user_id=6380

Thank you.

I've moved this feature request to PEP 42, "Feature Requests".
msg53133 - (view) Author: Dustin J. Mitchell (djmitche) * Date: 2007-01-03 04:30
I have a potential implementation for this, intended to be included in Lib/tempfile.py.  Because the issue is closed, I can't attach it.  Let's see if posting to the issue will open that option up.

Dustin
msg53134 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-01-03 04:52
I've reopened the issue for you.  Do try to interest some other core developer in reviewing your code, or it will take a long time...  Thanks for remembering!
msg53135 - (view) Author: Dustin J. Mitchell (djmitche) * Date: 2007-01-07 20:36
Patch is at http://python.org/sf/1630118
msg53136 - (view) Author: Collin Winter (collinwinter) * (Python committer) Date: 2007-03-19 18:53
Patch #1630118 checked in as r54439.
History
Date User Action Args
2001-04-12 15:37:57gvanrossumcreate