classification
Title: Path.mkdir and os.mkdir don't respect setgid if its parent is g-s
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Xophmeister, serhiy.storchaka
Priority: normal Keywords:

Created on 2020-07-28 14:54 by Xophmeister, last changed 2020-08-07 06:10 by Jeffrey.Kintscher. This issue is now closed.

Messages (2)
msg374496 - (view) Author: Christopher Harrison (Xophmeister) Date: 2020-07-28 14:54
The setgid bit is not set when creating a directory, even when explicitly specified in the mode argument, when its containing directory doesn't have its own setgid bit set. When the parent does have the setgid bit, it works as expected.

Steps to reproduce:

1. Outside of Python, create a working directory with mode 0770, such that:

   >>> from pathlib import Path
   >>> oct(Path().stat().st_mode)
   '0o40770'

2. Set the umask to 0, to be sure it's not a masking issue:

   >>> import os
   >>> _ = os.umask(0)

3. Create a subdirectory with mode ug+rwx,g+s (2770):

   >>> (test := Path("test")).mkdir(0o2770)
   >>> oct(test.stat().st_mode)
   '0o40770'

   Notice that setgid is not respected.

4. Set setgid to the working directory:

   >>> Path().chmod(0o2770)
   >>> oct(Path().stat().st_mode)
   '0o42770'

   This works as expected.

5. Create another subdirectory with mode ug+rwx,g+s:

   >>> (test2 := Path("test2")).mkdir(0o2770)
   >>> oct(test2.stat().st_mode)
   '0o42770'

   The setgid bit of the new directory is now correctly set.

This also affects os.mkdir.

I have only tested this under Python 3.8.2 and 3.8.3 on a POSIX filesystem. (I assume it's not relevant to non-POSIX filesystems.)
msg374979 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2020-08-07 06:01
os.mkdir() is a thin wrapper around syscalls mkdir or mkdirat. Path.mkdir() is a thin wrapper around os.mkdir(). If you think that the behavior of mkdir differs from the documentation please file a report in the Linux kernel.
History
Date User Action Args
2020-08-07 06:10:10Jeffrey.Kintschersetnosy: - Jeffrey.Kintscher
2020-08-07 06:01:48serhiy.storchakasetstatus: open -> closed

nosy: + serhiy.storchaka
messages: + msg374979

resolution: not a bug
stage: resolved
2020-08-07 02:53:51Jeffrey.Kintschersetnosy: + Jeffrey.Kintscher
2020-07-28 14:54:47Xophmeistercreate