classification
Title: Unable to uninstall Python launcher using command line
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.8
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: WildCard65, hap, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2020-07-21 10:39 by hap, last changed 2020-07-24 06:17 by hap. This issue is now closed.

Messages (3)
msg374063 - (view) Author: hap (hap) Date: 2020-07-21 10:39
Trying to create a command line keeping the following in mind, and my script is python-3.8.4.exe" /quiet InstallLauncherAllUsers=0 Include_pip=1 Include_tcltk=1 Include_test=1 PrependPath=1
1. Python installs in user profile
2. Install pip as a part of installation
All good here. 
So, my script installs python and also installs Python Launcher.

So far so good!

The problem is, when uninstall python i use command "python-3.8.4.exe" /quiet /uninstall, it does uninstall python, but this does not uninstall Python Launcher. Therefore, i call msiexec.exe /x {339192BE-2520-4C34-89DF-81CF98EB7E6C} /qn+ and it does remove all components from %localappdata%\Package Cache folder, except that it still keeps launcher.msi (588kb) and also entry in appwiz.cpl (around 7.15 MB).

What i am trying to achieve is,
1. If user wants to uninstall Python, it should uninstall python and python launcher because i don't want to leave away any installer files which an contribute to my system space.

I have gone through many links with failed help. Any suggestion to save my 7.2 MB space is greatly appreciated.
msg374141 - (view) Author: William Pickard (WildCard65) * Date: 2020-07-23 15:34
I think on Windows, the Python Launcher is a separate install entity.

You can verify this under Control Panel -> Uninstall Program and Features.
msg374161 - (view) Author: hap (hap) Date: 2020-07-24 06:17
Run msiexec.exe /x {339192BE-2520-4C34-89DF-81CF98EB7E6C} /qn+ fixed it
History
Date User Action Args
2020-07-24 06:17:08hapsetstatus: open -> closed

messages: + msg374161
stage: resolved
2020-07-23 15:34:40WildCard65setnosy: + WildCard65
messages: + msg374141
2020-07-22 08:05:08ned.deilysetnosy: + paul.moore, tim.golden, zach.ware, steve.dower
components: + Windows
2020-07-21 10:39:57hapcreate