classification
Title: Build failure in blurb-it repo: "Failed building wheel for yarl"
Type: compile error Stage: resolved
Components: Versions: Python 3.10
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: Mariatta, asvetlov, methane, ned.deily, vstinner
Priority: normal Keywords:

Created on 2020-07-17 18:18 by Mariatta, last changed 2020-08-04 02:32 by methane. This issue is now closed.

Messages (6)
msg373843 - (view) Author: Mariatta (Mariatta) * (Python committer) Date: 2020-07-17 18:18
We're seeing travis CI build failure against the nightly Python build v3.10.0a0.

Build log: https://travis-ci.org/github/python/blurb_it/jobs/707532881

Last few lines of the build log:


In file included from /opt/python/3.10-dev/include/python3.10/unicodeobject.h:1026:0,
                   from /opt/python/3.10-dev/include/python3.10/Python.h:97,
                   from yarl/_quoting.c:4:
  /opt/python/3.10-dev/include/python3.10/cpython/unicodeobject.h:551:42: note: declared here
   Py_DEPRECATED(3.3) PyAPI_FUNC(PyObject*) PyUnicode_FromUnicode(
                                            ^
  yarl/_quoting.c: In function ‘__Pyx_decode_c_bytes’:
  yarl/_quoting.c:9996:9: warning: ‘PyUnicode_FromUnicode’ is deprecated [-Wdeprecated-declarations]
           return PyUnicode_FromUnicode(NULL, 0);
           ^
  In file included from /opt/python/3.10-dev/include/python3.10/unicodeobject.h:1026:0,
                   from /opt/python/3.10-dev/include/python3.10/Python.h:97,
                   from yarl/_quoting.c:4:
  /opt/python/3.10-dev/include/python3.10/cpython/unicodeobject.h:551:42: note: declared here
   Py_DEPRECATED(3.3) PyAPI_FUNC(PyObject*) PyUnicode_FromUnicode(
                                            ^
  error: command '/usr/bin/gcc' failed with exit code 1
  ----------------------------------------
  ERROR: Failed building wheel for yarl


I'm not familiar with that part of codebase. If anyone has any insight, it would be appreciated. Thanks.
msg373844 - (view) Author: Mariatta (Mariatta) * (Python committer) Date: 2020-07-17 18:20
Adding Victor Stinner to nosy
msg373893 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-07-18 09:29
blurb-it imports aiohttp which imports yarl. It might be a duplicate of https://github.com/aio-libs/yarl/issues/459
msg374771 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-08-03 23:45
yarl is a third party project, you should report the issue to https://github.com/aio-libs/yarl/

> blurb-it imports aiohttp which imports yarl. It might be a duplicate of https://github.com/aio-libs/yarl/issues/459

Andrew Svetlov wrote "yarl 1.5.0 will be published with generated C files made by Cython 0.29.21"

At https://pypi.org/project/yarl/ I can see version 1.5.1.

I guess that the issue is now fixed.
msg374772 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-08-03 23:46
> I'm not familiar with that part of codebase. If anyone has any insight, it would be appreciated. Thanks.

See PEP 623 if you're curious ;-)
msg374786 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2020-08-04 02:32
For the record, deprecation warning is just a waring. Build failure is coming from here:

```
  yarl/_quoting.c:1245:23: error: lvalue required as left operand of assignment
           Py_SIZE(list) = len+1;
```

It is not relating PEP 623, and it has been fixed already.
History
Date User Action Args
2020-08-04 02:32:03methanesetnosy: + methane
messages: + msg374786
2020-08-03 23:46:21vstinnersetmessages: + msg374772
2020-08-03 23:45:13vstinnersetstatus: open -> closed
resolution: third party
messages: + msg374771

stage: resolved
2020-07-18 09:29:48ned.deilysetnosy: + asvetlov, ned.deily
messages: + msg373893
2020-07-17 18:20:09Mariattasetnosy: + vstinner
messages: + msg373844
2020-07-17 18:18:11Mariattacreate