classification
Title: ipaddress module doesn't recognize 100.64.0.0/10 as a private network
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.10, Python 3.9, Python 3.8, Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Allayna Wilson, SilentGhost, pitrou
Priority: normal Keywords:

Created on 2020-07-13 11:22 by Allayna Wilson, last changed 2020-07-13 11:51 by SilentGhost. This issue is now closed.

Messages (2)
msg373592 - (view) Author: Allayna Wilson (Allayna Wilson) Date: 2020-07-13 11:22
import IPv4Address as n4

In [10]: n4('100.64.0.0/24').is_private                                                                                     
Out[10]: False

In [11]: n4('100.64.0.0/10').is_private                                                                                     
Out[11]: False

https://en.wikipedia.org/wiki/Reserved_IP_addresses#IPv4

keep this on the dl though I don't want anybody else using this /10. I'm tired of people's crap always overlapping with my private networks.
msg373596 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2020-07-13 11:51
This was an intentional change, see #17400 and specifically commit 49e012e5492c1c70690ab72a8d03a980047148b5; so I'm going to close this issue as not a bug.
History
Date User Action Args
2020-07-13 11:51:48SilentGhostsetstatus: open -> closed

nosy: + SilentGhost
messages: + msg373596

resolution: not a bug
stage: resolved
2020-07-13 11:44:02SilentGhostsetnosy: + pitrou

components: - Extension Modules
versions: - Python 3.5, Python 3.6
2020-07-13 11:22:25Allayna Wilsoncreate