classification
Title: Attribute error: Pandas module doesn't have 'Plotting' attribute
Type: Stage: resolved
Components: Windows Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eric.smith, owais.ali, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2020-07-10 10:43 by owais.ali, last changed 2020-07-10 10:49 by eric.smith. This issue is now closed.

Files
File name Uploaded Description Edit
Error.zip owais.ali, 2020-07-10 10:43 Erro Image and the installed dependencies on server. The project directory
Messages (2)
msg373461 - (view) Author: owais (owais.ali) * Date: 2020-07-10 10:43
Hello... I am deploying a django application over the AWS Cloud Server EC2 windows instance having AMD64 architecture. I have installed python 3.7.6 over the server and install all modules (numpy pandas matplotlib django etc) using pip. I have set the sqlite server on AWS. I changed the path variables from local dir to server dir and also change the database server name. but When I run the server from cmd by typing "python manage.py runserver" I am facing an issue/error that says pandas module does not have plotting module. Whereas I checked in site-pakages under pandas folder, there is a subfolder named as 'plotting'. I have again installed the newer version of pip by upgrade pip command then install the pandas but no success acheived. Kindly help me out I am attaching 2 pictures, one is the error and other is project directory where all scripts are present.
msg373462 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2020-07-10 10:49
This bug tracker is for reporting bugs in python, not for getting help using python.

I suggest asking for help on the python-list mailing list: https://mail.python.org/mailman/listinfo/python-list

Or, since this sounds like you're having problems with pandas, perhaps a pandas-specific forum would be better. I'm not familiar with the pandas community to know where you should look, sorry.
History
Date User Action Args
2020-07-10 10:49:06eric.smithsetstatus: open -> closed

type: performance ->

nosy: + eric.smith
messages: + msg373462
resolution: not a bug
stage: resolved
2020-07-10 10:43:52owais.alicreate