classification
Title: warning: 'Tk_MainWindow' is deprecated: first deprecated
Type: compile error Stage: resolved
Components: macOS Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: nanjekyejoannah, ned.deily, ronaldoussoren, svaddi
Priority: normal Keywords:

Created on 2020-06-17 23:30 by svaddi, last changed 2020-07-06 10:09 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
python.compile.log svaddi, 2020-06-17 23:30
Messages (2)
msg373046 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2020-07-05 20:39
I find this issue to be less descriptive. Maybe a sentence to complement the title can help others understand even better.
msg373088 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-07-06 10:09
The deprecation warnings are a specific "feature" of the copy of Tcl/Tk shipped by Apple, and do not reflect the status of this API upstream.

The correct fix is to either ignore these warnings when building, or better to use a different install of Tcl/Tk (later versions are substantially better, which is why the Python.org installers for macOS ship with a copy of Tcl/Tk).
History
Date User Action Args
2020-07-06 10:09:58ronaldoussorensetstatus: open -> closed
type: compile error
messages: + msg373088

resolution: not a bug
stage: resolved
2020-07-05 20:39:27nanjekyejoannahsetnosy: + nanjekyejoannah
messages: + msg373046
2020-06-17 23:30:13svaddicreate