classification
Title: warning: 'sqlite3_trace' is deprecated
Type: compile error Stage: resolved
Components: macOS Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: erlendaasland, nanjekyejoannah, ned.deily, ronaldoussoren, svaddi
Priority: normal Keywords:

Created on 2020-06-17 23:26 by svaddi, last changed 2020-07-20 19:40 by erlendaasland. This issue is now closed.

Files
File name Uploaded Description Edit
python.compile.log svaddi, 2020-06-17 23:26
Messages (4)
msg371784 - (view) Author: Sree Vaddi (svaddi) * Date: 2020-06-17 23:26
details in the attached python.compile.log
msg373163 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2020-07-06 19:45
I think the same reasoning in the discussion from this thread: https://bugs.python.org/issue41018 applies to this too.
msg373169 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-07-06 20:24
I agree, this is a "feature" of the SQLite headers as shipped by Apple.
msg374023 - (view) Author: Erlend E. Aasland (erlendaasland) * (Python triager) Date: 2020-07-20 19:40
According to the SQLite documentation, sqlite3_trace() is deprecated. See https://sqlite.org/c3ref/profile.html

See also:
https://bugs.python.org/issue40318
https://github.com/python/cpython/pull/19581
History
Date User Action Args
2020-07-20 19:40:41erlendaaslandsetnosy: + erlendaasland
messages: + msg374023
2020-07-06 20:24:04ronaldoussorensetstatus: open -> closed
type: enhancement -> compile error
messages: + msg373169

resolution: not a bug
stage: resolved
2020-07-06 19:45:12nanjekyejoannahsetnosy: + nanjekyejoannah
messages: + msg373163
2020-06-17 23:28:16svaddisettitle: sqlite3_trace deprecated -> warning: 'sqlite3_trace' is deprecated
2020-06-17 23:26:07svaddicreate