classification
Title: Better identify Windows installer as installer only, not runner
Type: Stage: resolved
Components: Windows Versions: Python 3.10, Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: miss-islington, mwichmann, ned.deily, paul.moore, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords: patch

Created on 2020-06-11 12:04 by terry.reedy, last changed 2020-07-28 16:54 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
postinstall.png steve.dower, 2020-07-28 11:41
Pull Requests
URL Status Linked Edit
PR 21656 merged steve.dower, 2020-07-28 11:45
PR 21661 merged miss-islington, 2020-07-28 15:35
Messages (12)
msg371263 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-06-11 12:04
Some beginners on Windows think that python-3.8.3-amd64.exe, for instance, is for running python-3.8.3, leading to repeated and now tiresome questions on python-list and probably elsewhere.  The latest example is "repair modify uninstall" with the core complaint that "after downloading and trying to launch it keeps saying repair modify uninstall".  (Actually, 'modify' comes first.)

In response, Grant Edwards suggested adding run instructions to the initial screen and asked a "Is the file name not clear that it's an installer?"

For the naive, the answer, as is traditional, is 'no'. How about adding 'setup' or 'install', as I have seen occasionally.
  python-3.8.3-amd64-setup.exe

The initial screen is different according to whether an installed binary is absent or present.  For the latter, add something like

Python 3.8.3 {n} bit is installed for {who}.
To run it, {directions}
To change it, click one of the buttons below.

An optional add-on would be a button to open the doc page on using python on Windows.

(I an not suggesting a button to actually run python.exe from the installer.  Users should really learn how to start it properly according to platform and python-specific conventions and their particular needs.)

Does the final screen after installation say anything about running the new install?  (I cannot remember.)

Ned: I don't think that this issue afficts Mac newbies.  Perhaps python-xyz.pkg is more clearly not for running.  But something you might watch for.
msg371302 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-06-11 16:16
The current "using" doc page is way too in-depth, but I'm actually okay with the idea of having a "Did you mean to launch Python? Press 'Start' and type 'Python' to find it" message on the Modify page of the installer.

Perhaps the people hitting this problem would read the final page of the installer, but I suspect they're just like everyone else and don't read instructions until just-in-time. So if they're reaching the Modify page, that's the place to put them.
msg371326 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-06-12 00:32
Simple is fine.  How about

If you want to run Python, press Start and find 'Python 3.x' under 'P', or enter 'python' in the "Search for anything" box on the taskbar.

If you don't have the time right now, where should this go?
msg371457 - (view) Author: Mats Wichmann (mwichmann) * Date: 2020-06-13 14:55
"on python-list and probably elsewhere"... I can confirm these questions get mailed to webmaster@python.org :)   A couple of comments since I see these fairly frequently:

The "using" doc page may have too much information for beginner tastes, but at least it answers a lot of questions. but it's hard to find... it would be nice if the OS-specific installation page actually pointed to it - or to a more concise alternative if that's preferred. Applies to Mac as well, as most people who install on Mac seem to have some surprise with it not launching the way they expect.

Proposed text: "If you want to run Python, press Start and find 'Python 3.x' under 'P', or enter 'python' in the "Search for anything" box on the taskbar." - why not mention the Python Launcher here? Isn't that the preferred approach now for the pydotorg installer?
msg371462 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-06-13 16:39
Mats, thank you for chiming in.  py.exe is preferred *if* one starts python from a command line.  Some beginners have never seen one or know what it is.  This is most likely to be true of people who don't know 'installer' from 'launcher'.  The installer is usually launched from a browswer or possibly Explorer, not a console.

That said, I would not mind also linking to whatever page, but I agree now with Steve about starting with something minimal that works, at least if the default 'install icons' was left checked.
msg371465 - (view) Author: Mats Wichmann (mwichmann) * Date: 2020-06-13 17:12
> py.exe is preferred *if* one starts python from a command line.

I'm not a habitual Windows user (a certain project is making me spend way more time there than usual), but if I start typing python to a Windows search, after the first two letters the launcher is usually the highlighted match ("Best match" it says on Win10), so it's not *just* from the command line.
msg374484 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-07-28 11:05
Assuming it fits, I'm going to update the 3.9+ post-install message to this (assume the HTML renders normally). Any comments?


New to Python? Start with the <a href="https://docs.python.org/[ShortVersion]/tutorial/index.html">online tutorial</a> and <a href="https://docs.python.org/[ShortVersion]/index.html">documentation</a>.

At your terminal, type "py" to launch Python, or search for Python in your Start menu.

See <a href="https://docs.python.org/[ShortVersion]/whatsnew/[ShortVersion].html">what's new</a> in this release.

Special thanks to Mark Hammond, without whose years of freely shared Windows expertise, Python for Windows would still be Python for DOS.
msg374487 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-07-28 11:41
Added a screenshot, after tweaking the spacing just a little.
msg374490 - (view) Author: Mats Wichmann (mwichmann) * Date: 2020-07-28 12:33
I still think there ought to be some pointer to https://docs.python.org/3/using/windows.html in there.
msg374491 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-07-28 13:35
I changed the middle paragraph to this:

See <a href="https://docs.python.org/[ShortVersion]/whatsnew/[ShortVersion].html">what's new</a> in this release, or find more info about <a href="https://docs.python.org/[ShortVersion]/using/windows.html">using Python on Windows</a>.
msg374503 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-07-28 15:36
New changeset 37a06cbe5c17c2aa6ad938339fd42531a8a0bea0 by Steve Dower in branch 'master':
bpo-41412 and bpo-40948: Windows installer updates (GH-21656)
https://github.com/python/cpython/commit/37a06cbe5c17c2aa6ad938339fd42531a8a0bea0
msg374505 - (view) Author: miss-islington (miss-islington) Date: 2020-07-28 15:55
New changeset 95cc37f6b8e895a5042e2a10e5d9026429e06342 by Miss Islington (bot) in branch '3.9':
bpo-41412 and bpo-40948: Windows installer updates (GH-21656)
https://github.com/python/cpython/commit/95cc37f6b8e895a5042e2a10e5d9026429e06342
History
Date User Action Args
2020-07-28 16:54:02steve.dowersetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2020-07-28 15:55:45miss-islingtonsetmessages: + msg374505
2020-07-28 15:36:07steve.dowersetmessages: + msg374503
2020-07-28 15:35:58miss-islingtonsetnosy: + miss-islington
pull_requests: + pull_request20808
2020-07-28 13:35:40steve.dowersetmessages: + msg374491
2020-07-28 12:33:37mwichmannsetmessages: + msg374490
2020-07-28 11:45:28steve.dowersetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request20801
2020-07-28 11:41:36steve.dowersetfiles: + postinstall.png

messages: + msg374487
2020-07-28 11:05:35steve.dowersetmessages: + msg374484
2020-06-13 17:12:44mwichmannsetmessages: + msg371465
2020-06-13 16:39:40terry.reedysetmessages: + msg371462
2020-06-13 14:55:23mwichmannsetnosy: + mwichmann
messages: + msg371457
2020-06-12 00:32:54terry.reedysetmessages: + msg371326
2020-06-11 16:16:22steve.dowersetmessages: + msg371302
2020-06-11 12:04:15terry.reedycreate