classification
Title: linking python2.6.dll crash on windows xp
Type: crash Stage:
Components: Windows Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Manuel, giampaolo.rodola
Priority: normal Keywords:

Created on 2008-10-09 15:40 by Manuel, last changed 2008-10-10 17:21 by theller. This issue is now closed.

Messages (4)
msg74582 - (view) Author: Manuel (Manuel) Date: 2008-10-09 15:40
On some machines, the application (makehuman, an open source software)
crash, immediately, as soon the user try to double click on the exe. The
problem happen with the version compiled using python 2.6, while the one
compiled with 2.5 work fine.

We have asked to our users to try the installation of  Visual C++ 2005
Redistributable Package, but this hasn't fixed the crash.

Both binary files (compiled using gcc and debug symbols with 2.5 and
with 2.6) are here:

http://www.makehuman.org/tmp/makehuman_test_python25_and_python26.zip

Furthermore:

Installing full python2.6 it work.
Unistalling full python2.6 it don't work.
Installing python26 and deleting C:/python26 folder (without unistall
it), it work again...

thx,

Manuel
msg74583 - (view) Author: Manuel (Manuel) Date: 2008-10-09 15:48
gdb output from one of our users:

------------------------------------
warning: LDR: LdrpWalkImportDescriptor() failed to probe python26.dll
for its manifest, ntstatus 0xc0150002


Program received signal SIGSEGV, Segmentation fault.

Program received signal SIGSEGV, Segmentation fault.

Program received signal SIGSEGV, Segmentation fault.

Program exited with code 030000000005.
You can't do that without a process to debug.
msg74623 - (view) Author: Manuel (Manuel) Date: 2008-10-10 09:02
We have fixed the problem installing this:

http://www.microsoft.com/downloads/details.aspx?FamilyID=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en

Anyway, before consider the bug solved, we need to test this solution on
different computers.
msg74625 - (view) Author: Manuel (Manuel) Date: 2008-10-10 09:57
Yes. This bug can be closed.
The use of python26.dll require last Microsoft Visual C++ 2008
Redistributable Package.
History
Date User Action Args
2008-10-10 17:21:48thellersetstatus: open -> closed
resolution: not a bug
2008-10-10 09:57:59Manuelsetmessages: + msg74625
2008-10-10 09:02:33Manuelsetmessages: + msg74623
2008-10-09 16:02:09giampaolo.rodolasetnosy: + giampaolo.rodola
2008-10-09 15:48:37Manuelsetmessages: + msg74583
2008-10-09 15:40:43Manuelcreate