classification
Title: _tkinter build failed when install Python-3.6.10
Type: compile error Stage: resolved
Components: Build Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Compilation Error with Python 3.6.1/3.6.3 with Tkinter
View: 31817
Assigned To: Nosy List: ned.deily, zhang
Priority: normal Keywords:

Created on 2020-05-29 09:17 by zhang, last changed 2020-05-29 10:24 by ned.deily. This issue is now closed.

Messages (3)
msg370281 - (view) Author: zhang (zhang) Date: 2020-05-29 09:17
building '_tkinter' extension
gcc -pthread -fPIC -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -DWITH_APPINIT=1 -I./Include -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python/Python-3.6.10/include -I. -I/usr/local/include -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Include -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10 -c /YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Modules/_tkinter.c -o build/temp.linux-x86_64-3.6/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Modules/_tkinter.o -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/tcltk/8.6.8/include/
gcc -pthread -fPIC -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -DWITH_APPINIT=1 -I./Include -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python/Python-3.6.10/include -I. -I/usr/local/include -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Include -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10 -c /YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Modules/tkappinit.c -o build/temp.linux-x86_64-3.6/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Modules/tkappinit.o -I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/tcltk/8.6.8/include/
gcc -pthread -shared build/temp.linux-x86_64-3.6/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Modules/_tkinter.o build/temp.linux-x86_64-3.6/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python-3.6.10/Modules/tkappinit.o -L/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/Python/Python-3.6.10/lib -L/usr/local/lib -o build/lib.linux-x86_64-3.6/_tkinter.cpython-36m-x86_64-linux-gnu.so -L/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T06/zhangxq/software/tcltk/8.6.8/lib/
warning: building with the bundled copy of libffi is deprecated on this platform.  It will not be distributed with Python 3.7
*** WARNING: renaming "_tkinter" since importing it failed: build/lib.linux-x86_64-3.6/_tkinter.cpython-36m-x86_64-linux-gnu.so: undefined symbol: Tcl_GetCharLength
msg370282 - (view) Author: zhang (zhang) Date: 2020-05-29 09:19
configure command :./configure --prefix=/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T/zzz/software/Python/Python-3.6.10/ --with-tcltk-includes='-I/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T/zzz/software/tcltk/8.6.8/include/' --with-tcltk-libs='-L/YZGROUP4/STORAGE/personalbio/Work/Transcriptome/T/zzz/software/tcltk/8.6.8/lib/'
msg370291 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-05-29 10:24
Since you have already found and commented on Issue31817, closing this as a duplicate of it.
History
Date User Action Args
2020-05-29 10:24:15ned.deilysetstatus: open -> closed

superseder: Compilation Error with Python 3.6.1/3.6.3 with Tkinter

nosy: + ned.deily
messages: + msg370291
resolution: duplicate
stage: resolved
2020-05-29 09:19:02zhangsetmessages: + msg370282
2020-05-29 09:17:07zhangcreate