classification
Title: Cannot build non-framework tkinter Python on Mac OS X.5
Type: behavior Stage:
Components: Build Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: indiedan
Priority: normal Keywords:

Created on 2008-10-08 14:09 by indiedan, last changed 2008-10-09 19:40 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg74528 - (view) Author: Dan OD (indiedan) Date: 2008-10-08 14:09
On a Mac running OS X 10.5:
As per previous releases, I have set up _tkinter in Modules/Setup.dist 
with a unix X11 Tcl/Tk build variables. 
I then run ./configure && make

This builds _tkinter with (wrongly) the Mac Tcl framework (ie not X11)

building '_tkinter' extension
gcc-4.2 -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-
prototypes -DWITH_APPINIT=1 -
I/System/Library/Frameworks/Tcl.framework/Headers -
I/System/Library/Frameworks/Tcl.framework/Versions/Current/PrivateHeader
s -I/System/Library/Frameworks/Tk.framework/Headers -
I/System/Library/Frameworks/Tk.framework/Versions/Current/PrivateHeaders 
-I/usr/X11R6/include -I. -I/Users/djo35/src/Python-3.0rc1/./Include -I. 
-IInclude -I./Include -I/usr/local/include -I/Users/djo35/src/Python-
3.0rc1/Include -I/Users/djo35/src/Python-3.0rc1 -c 
/Users/djo35/src/Python-3.0rc1/Modules/_tkinter.c -o build/temp.macosx-
10.3-i386-3.0/Users/djo35/src/Python-3.0rc1/Modules/_tkinter.o -
framework Tk

I would like this to build a unix tkinter.so - is this possible? I can't 
find a reference in the 3k documentation. Thanks, Dan
msg74579 - (view) Author: Dan OD (indiedan) Date: 2008-10-09 14:56
Confusion - apologies - please remove this report.
History
Date User Action Args
2008-10-09 19:40:34amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
2008-10-09 14:56:25indiedansetmessages: + msg74579
2008-10-08 14:09:34indiedancreate