classification
Title: command 'elif' does not work
Type: compile error Stage: resolved
Components: IDLE Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: terry.reedy Nosy List: Jonny Li, terry.reedy, xtreak
Priority: normal Keywords:

Created on 2020-05-24 02:57 by Jonny Li, last changed 2020-05-24 11:15 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
Screen Shot 2020-05-24 at 10.56.55.png Jonny Li, 2020-05-24 02:57
Screen Shot 2020-05-24 at 10.56.10.png Jonny Li, 2020-05-24 03:00
Messages (2)
msg369766 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-05-24 03:14
You're indenting elif inside if clause. The elif should be of same indentation length like if condition.
msg369787 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-05-24 11:15
Beginners should ask on python-list or elsewhere whether something is a bug before posting here.
History
Date User Action Args
2020-05-24 11:15:58terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg369787

stage: resolved
2020-05-24 03:14:54xtreaksetnosy: + xtreak
messages: + msg369766
2020-05-24 03:00:42Jonny Lisetfiles: + Screen Shot 2020-05-24 at 10.56.10.png
2020-05-24 02:57:34Jonny Licreate