classification
Title: Missing api-ms-win-core-path-l1-1.0.dll for python-3.9.0b1-amd64.exe Under Win7
Type: crash Stage: resolved
Components: Windows Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: honglei.jiang, lukasz.langa, mhammond, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2020-05-23 09:11 by honglei.jiang, last changed 2020-06-15 14:16 by steve.dower. This issue is now closed.

Messages (4)
msg369707 - (view) Author: honglei jiang (honglei.jiang) * Date: 2020-05-23 09:11
Python.exe cannot run for missing  api-ms-win-core-path-l1-1.0.dll ,

api-ms-win-core-path-l1-1-0.dll is for only Windows 8?

https://github.com/microsoft/CNTK/issues/224
msg369910 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-05-25 19:23
Sorry, Windows 7 is no longer supported in Python 3.9. You'll need to update, ideally to Windows 10, but if you want to stay on Windows 8.1 then I believe that one's supported until Python 3.10.
msg371437 - (view) Author: Mark Hammond (mhammond) * (Python committer) Date: 2020-06-13 05:14
Can we get this mentioned somewhere? Eg, https://www.python.org/downloads/release/python-390b3/ doesn't mention anything about minimum versions. https://www.python.org/downloads/windows/ also has prominent notices like "Note that Python 3.8.3rc1 cannot be used on Windows XP or earlier." but nothing for 3.9

(This threw me for some time - I still have a win7 VM I used for testing and figured there was something broken in the VM before finding this)
msg371548 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2020-06-15 14:16
Ɓukasz can add a note to the release page, I believe.
History
Date User Action Args
2020-06-15 14:16:12steve.dowersetnosy: + lukasz.langa
messages: + msg371548
2020-06-13 05:14:55mhammondsetnosy: + mhammond
messages: + msg371437
2020-05-25 19:23:06steve.dowersetstatus: open -> closed
resolution: not a bug
messages: + msg369910

stage: resolved
2020-05-23 09:11:53honglei.jiangcreate