classification
Title: fstrings are not docstrings
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.8, Python 3.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: radkujawa
Priority: normal Keywords:

Created on 2020-05-21 11:02 by radkujawa, last changed 2020-05-21 11:15 by radkujawa. This issue is now closed.

Messages (2)
msg369518 - (view) Author: radkujawa (radkujawa) Date: 2020-05-21 11:02
see example:

>>> def f():
...     f"""asdf"""
...     pass
... 
>>> f.__doc__
>>> def f():
...     """asdf"""
...     pass
... 
>>> f.__doc__
'asdf'
>>>
msg369519 - (view) Author: radkujawa (radkujawa) Date: 2020-05-21 11:15
duplicate of https://bugs.python.org/issue28739

behaviour described in:
https://docs.python.org/3/reference/lexical_analysis.html#formatted-string-literals
History
Date User Action Args
2020-05-21 11:15:03radkujawasetstatus: open -> closed

messages: + msg369519
stage: resolved
2020-05-21 11:02:48radkujawacreate