classification
Title: test_mboxmmdf_to_maildir fails on non-englisch locale
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, oefe, r.david.murray
Priority: normal Keywords:

Created on 2008-10-05 12:32 by oefe, last changed 2010-07-11 14:55 by r.david.murray. This issue is now closed.

Messages (5)
msg74340 - (view) Author: Martina Oefelein (oefe) Date: 2008-10-05 12:32
test_mboxmmdf_to_maildir (in test_mailbox.py) fails if the environment 
variable LANG is set to a non-english locale.

Python 3.0rc1 on MacOSX 10.5.5

Majestix:Python-3.0rc1 martina$ LANG=en_US.UTF-8 ./python.exe -E -bb 
./Lib/test/regrtest.py -l test_mailbox
test_mailbox
1 test OK.
Majestix:Python-3.0rc1 martina$ LANG=de_DE.UTF-8 ./python.exe -E -bb 
./Lib/test/regrtest.py -l test_mailbox
test_mailbox
test test_mailbox failed -- Traceback (most recent call last):
  File "/Users/martina/Downloads/Python-
3.0rc1/Lib/test/test_mailbox.py", line 1389, in test_mboxmmdf_to_maildir
    self.assert_(msg.get_date() == 0.0, msg.get_date())
AssertionError: 1223209655.11
msg109572 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-07-08 19:05
I can't reproduce this on Windows Vista despite setting the system locale to Dutch.  Is the problem Mac OSx specific?
msg109786 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-07-09 19:12
After testing 4044, I suspect this has more to do with the specific user environment than it does with Python.  My guess would be that someone is setting the locale in site.py, or some module is getting imported on startup that is setting the locale.

Closing as works for me, the OP can reopen if they still have the problem and still think it is a python bug.
msg110018 - (view) Author: Martina Oefelein (oefe) Date: 2010-07-11 14:41
Did you test it Python *3.0*? Apparently, the issue does not happen in Python 2.x, and also not in Python 3.1.2.

Apparently it was introduced somewhere in Python 3.0, and later fixed. 

I retested the issue in Python 3.0.1 on Mac OS X 10.6.4, using a freshly unpacked tarball, built with

./configure && make

and it still happens. To avoid influences of the user environment, I repeated the test in a newly created test account. Same issue.

The issue doesn't happen in Python 2.6, 2.6.5, 2.7, or 3.1.2, however.
msg110022 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-07-11 14:55
Ah, OK, thanks for the clarification.  3.0 is no longer receiving bug fixes.  I'll change the resolution to 'out of date', though.
History
Date User Action Args
2010-07-11 14:55:07r.david.murraysetresolution: works for me -> out of date
messages: + msg110022
2010-07-11 14:46:09ezio.melottisetstatus: open -> closed
2010-07-11 14:41:37oefesetmessages: + msg110018
2010-07-09 19:12:59r.david.murraysetnosy: + r.david.murray
messages: + msg109786

resolution: works for me
stage: resolved
2010-07-08 19:05:35BreamoreBoysetnosy: + BreamoreBoy

messages: + msg109572
versions: + Python 3.1, Python 2.7, Python 3.2, - Python 3.0
2008-10-05 12:33:50oefesettype: behavior
2008-10-05 12:32:44oefecreate