classification
Title: IDLE won't start in 2.6 final. A known fix was overlooked?
Type: crash Stage:
Components: IDLE Versions: Python 2.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, loewis, rbtyod
Priority: normal Keywords:

Created on 2008-10-04 22:07 by rbtyod, last changed 2008-10-05 19:15 by loewis. This issue is now closed.

Messages (7)
msg74321 - (view) Author: Robert Yodlowski (rbtyod) Date: 2008-10-04 22:07
I just installed the 2.6 final release on my fully updated Win XP
system. When I tried to run IDLE I got the same... 

"IDLE's subprocess didn't make connection. Either IDLE can't start
subprocess or personal firewall is blocking." 

...fatal error message I got when I installed the last release candidate
version on Sept 22, 2008. I put in a bug report at that time 

"[issue3943] IDLE won't start in 3.0rc1 "Subprocess didn't make
connection"" 

but it was closed since the fix to LIB/idlelib/run.py (on line 76) in
#3905 message 73496 by Georg Brandl fixes this problem.

I believe that this known fix was overlooked when 2.6 final was released
this week.

...Bob
msg74322 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-10-04 22:27
IDLE 2.6 final works for me.
(I believe that #3905 did not apply to 2.6)

Can you please open a command prompt, and start IDLE from there?
If you installed python in the default location, the command is:

  C:\python26\python C:\python26\Lib\idlelib\idle

You should see interesting error messages there.
msg74323 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-10-04 22:28
Sorry, copy/paste error. The correct command is of course:

  C:\python26\python C:\python26\Lib\idlelib\idle.py
msg74331 - (view) Author: Robert Yodlowski (rbtyod) Date: 2008-10-04 23:49
Amaury, when I tried to run IDLE from the command line as you suggested
I got:

C:\>C:\python26\Lib\idlelib\idle.py
IDLE Subprocess: socket error: An attempt was made to access a socket in
a way forbidden by its access permissions, retrying....
IDLE Subprocess: socket error: An attempt was made to access a socket in
a way forbidden by its access permissions, retrying....
IDLE Subprocess: socket error: An attempt was made to access a socket in
a way forbidden by its access permissions, retrying....
IDLE Subprocess: Connection to IDLE GUI failed, exiting.

...followed by 2 error windows:

Socket Error:An attempt was made to access a socket in a way forbidden
by its access permissions

and...

IDLE's subprocess didn't make connection. Either IDLE can't start a
subprocess or personal firewall software is blocking the connection

...BUT when I try to run IDLE from the "all programs" menu it runs just
fine - which it did NOT when I created today's bug report.

To try to reproduce the original behavior, I first put back the unfixed
version of run.py and IDLE STILL RAN FINE from the program menu 

I was VERY confused at this point and I completely uninstalled Python2.6
and reinstalled it from the same .msi installer I used before.

After I reinstalled 2.6, IDLE again ran fine from the programs menu
WITHOUT making the fix in run.py but NOT from the command line -
producing the same error messages as at the top of this entry.

Right now I am so confused I don't know what to do. I cannot reproduce 
the original problem I reported in this bug report and IDLE runs fine
from the menu but not from the command line.

It know that IDLE would not run from the programs menu until I changed
run.py but once I did that, removing the fix seems to make no
difference. (I've been careful to remove the run.pyc file each time.) I
believe that the behavior I saw today with 2.6 was the same as I saw on
Sept 22 with 3.0 when I submitted #3943 - and with the same confusing
property where the fix is needed to make IDLE run but removing it makes
no difference.

I hope this makes sense to you. It doesn't to me.

...Bob
msg74335 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-10-05 04:55
> Amaury, when I tried to run IDLE from the command line as you suggested
> I got:
> 
> C:\>C:\python26\Lib\idlelib\idle.py

This is not what Amaury suggested. He suggested that you put the path
to python.exe before the path of idle.py
msg74351 - (view) Author: Robert Yodlowski (rbtyod) Date: 2008-10-05 18:53
Problem Solved. It was my firewall.

When I ran IDLE from the command line (the RIGHT way this time), in
addition to the error messages and popup windows that I got before, I
also got a popup window from my firewall asking if I was willing to
grant Python access permission. I granted permission and, when I tried
starting IDLE again, everything worked just fine.

Thank you, Amaury and Martin, for your help and your patience with me.

...Bob
msg74352 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-10-05 19:15
Closing as "works for me", then.
History
Date User Action Args
2008-10-05 19:15:09loewissetstatus: open -> closed
resolution: works for me
messages: + msg74352
2008-10-05 18:53:39rbtyodsetmessages: + msg74351
2008-10-05 04:55:52loewissetmessages: + msg74335
2008-10-04 23:50:00rbtyodsetmessages: + msg74331
2008-10-04 22:32:12loewissetnosy: + loewis
2008-10-04 22:28:29amaury.forgeotdarcsetmessages: + msg74323
2008-10-04 22:27:22amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg74322
2008-10-04 22:07:52rbtyodcreate