classification
Title: OS-related test failures on Linux in Python 3.8.2
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Dennis Sweeney, Steven Fleck
Priority: normal Keywords:

Created on 2020-04-24 19:48 by Steven Fleck, last changed 2020-10-20 02:23 by gregory.p.smith. This issue is now closed.

Files
File name Uploaded Description Edit
python_3.8.2_installation.txt Steven Fleck, 2020-04-24 19:48 configure, make, and make test outputs
Messages (2)
msg367215 - (view) Author: Steven Fleck (Steven Fleck) * Date: 2020-04-24 19:48
I'm having some issues with installing python 3.8.2. I'm installing it in my personal workspace on my university's computing resources (linux). I've installed many programs here, but python is giving me some issues. 

Ultimately, I'm failing 5 tests:
test_multiprocessing_forkserver 
test_pathlib
test_resource
test_socket 
test_zipfie

Any help into what I can do to fix these errors would be greatly appreciated. I've attached a file that has the outputs of each command listed below. I hope it helps

line 0001: ./configure
line 0754: make
line 1238: make test
line 3539: make test TESTOPTS="-v test_multiprocessing_forkserver test_pathlib test_resource test_socket test_zipfie"
msg367294 - (view) Author: Dennis Sweeney (Dennis Sweeney) * Date: 2020-04-26 05:05
Thanks for reaching out! This is about test failures, not problems with installation process, correct? I took a look at the failures:

======================================================================
ERROR: test_add_file_after_2107 (test.test_zipfile.StoredTestsWithSourceFile)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_zipfile.py", line 606, in test_add_file_after_2107
    os.utime(TESTFN, (ts, ts))
OSError: [Errno 75] Value too large for defined data type

----------------------------------------------------------------------

It looks like the test excepts an OverflowError but not an OSError, so I think it should do both.


======================================================================
ERROR: test_setrusage_refcount (test.test_resource.ResourceTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_resource.py", line 131, in test_setrusage_refcount
    resource.setrlimit(resource.RLIMIT_CPU, BadSequence())
ValueError: not allowed to raise maximum limit

----------------------------------------------------------------------

I think this is a bug in the test: a non-root process increasing its hard resource maximum should raise. So I think this maybe BadSequence()[i] should return limits[i].



======================================================================
FAIL: test_touch_common (test.test_pathlib.PosixPathTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_pathlib.py", line 1761, in test_touch_common
    self.assertGreaterEqual(st.st_mtime_ns, old_mtime_ns)
AssertionError: 1587754085552569712 not greater than or equal to 1587754085553625000

----------------------------------------------------------------------

Similar to: https://bugs.python.org/issue19715




======================================================================
FAIL: test_sendall_interrupted (test.test_socket.GeneralModuleTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_socket.py", line 1527, in test_sendall_interrupted
    self.check_sendall_interrupted(False)
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_socket.py", line 1514, in check_sendall_interrupted
    c.sendall(b"x" * support.SOCK_MAX_SIZE)
AssertionError: ZeroDivisionError not raised

======================================================================
FAIL: test_sendall_interrupted_with_timeout (test.test_socket.GeneralModuleTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_socket.py", line 1530, in test_sendall_interrupted_with_timeout
    self.check_sendall_interrupted(True)
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/test_socket.py", line 1514, in check_sendall_interrupted
    c.sendall(b"x" * support.SOCK_MAX_SIZE)
AssertionError: ZeroDivisionError not raised

----------------------------------------------------------------------

Looks related to https://bugs.python.org/issue18643 .
Perhaps SOCK_MAX_SIZE needs to be increased for this test, or be made system-dependent?



======================================================================
ERROR: test_ignore (test.test_multiprocessing_forkserver.TestIgnoreEINTR)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/gpfs/scratch/sjfleck/modulefiles/Python-3.8.2/Lib/test/_test_multiprocessing.py", line 4874, in test_ignore
    os.kill(p.pid, signal.SIGUSR1)
ProcessLookupError: [Errno 3] No such process

----------------------------------------------------------------------

Looks similar to: https://bugs.python.org/issue33532
History
Date User Action Args
2020-10-20 02:23:43gregory.p.smithsetstatus: open -> closed
resolution: not a bug
stage: resolved
2020-04-26 05:13:15Dennis Sweeneysettype: compile error -> behavior
components: + Tests, - Installation
title: Errors during make test python 3.8.2 -> OS-related test failures on Linux in Python 3.8.2
2020-04-26 05:05:52Dennis Sweeneysetnosy: + Dennis Sweeney
messages: + msg367294
2020-04-24 19:48:29Steven Fleckcreate