This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Darwin systems using win settings for webbrowser.py
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Webbrowser Module Cannot Find xdg-settings on OSX
View: 41754
Assigned To: Nosy List: Viraat Das, eric.araujo, ronaldoussoren
Priority: normal Keywords: patch

Created on 2020-04-22 08:01 by Viraat Das, last changed 2022-04-11 14:59 by admin. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 19649 open Viraat Das, 2020-04-23 01:53
Messages (4)
msg367036 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2020-04-22 17:56
Hello!  You didn’t give any information about the problem you found :)
msg367070 - (view) Author: Viraat Das (Viraat Das) * Date: 2020-04-23 01:53
When loading Jupyter Notebook, a NotADirectoryError: [Errno 20] Not a directory: 'xdg-settings' error was showing. This seems to be because Darwin systems were using Win settings. 

The pull request has addressed this by modifying the webbrowser.py code.
msg367072 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2020-04-23 02:29
xdg-settings is a program used on linux systems, not windows.  Also it is an executable file, not a directory, so something weird is going on.

Could you diagnose more?  The proposed PR does not seem to make sense: platform can’t be both darwin and win32/nt.
msg386627 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2021-02-08 12:36
This is a duplicate of #41754.
History
Date User Action Args
2022-04-11 14:59:29adminsetgithub: 84541
2021-02-08 17:07:52serhiy.storchakasetstatus: open -> closed
2021-02-08 12:36:29ronaldoussorensetnosy: + ronaldoussoren
messages: + msg386627
resolution: duplicate

superseder: Webbrowser Module Cannot Find xdg-settings on OSX
stage: patch review -> resolved
2020-04-23 02:29:58eric.araujosetmessages: + msg367072
2020-04-23 01:53:04Viraat Dassetkeywords: + patch

stage: patch review
messages: + msg367070
pull_requests: + pull_request18995
2020-04-22 17:56:20eric.araujosetnosy: - dstufft
messages: + msg367036

components: + Library (Lib), - Distutils
type: behavior
2020-04-22 08:01:54Viraat Dascreate