classification
Title: Tests failing with the latest update of openssl to version 1.1.1e
Type: Stage: resolved
Components: Library (Lib), SSL, Tests Versions: Python 3.9, Python 3.8, Python 3.7, Python 3.6, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: christian.heimes Nosy List: christian.heimes, cstratak
Priority: normal Keywords:

Created on 2020-03-22 19:36 by cstratak, last changed 2020-03-22 20:24 by cstratak. This issue is now closed.

Messages (2)
msg364818 - (view) Author: Charalampos Stratakis (cstratak) * Date: 2020-03-22 19:36
The fedora rawhide buildbots started failing due to the latest update of openssl to version 1.1.1e.

e.g. https://buildbot.python.org/all/#/builders/607/builds/137

Changelog: https://www.openssl.org/news/cl111.txt

The relevant info which seems to make the tests fail:

Properly detect EOF while reading in libssl. Previously if we hit an EOF while reading in libssl then we would report an error back to the application (SSL_ERROR_SYSCALL) but errno would be 0. We now add an error to the stack (which means we instead return SSL_ERROR_SSL) and therefore give a hint as to what went wrong.

Upstream PR: https://github.com/openssl/openssl/pull/10882

urllib3 issue: https://github.com/urllib3/urllib3/issues/1825
msg364820 - (view) Author: Charalampos Stratakis (cstratak) * Date: 2020-03-22 20:24
Closing it as duplicate of https://bugs.python.org/issue40018
History
Date User Action Args
2020-03-22 20:24:31cstrataksetstatus: open -> closed
resolution: duplicate
messages: + msg364820

stage: resolved
2020-03-22 19:36:36cstratakcreate